Fixing issues with Keyman and macOS Catalina

I think the forum ate some of the punctuation. Try this:

kill `pgrep Keyman`

Thanks, Makara, for making Marc spot the spice! phofarsi was fed, but still, I’m jinxed. And jumping around a half dozen devices with almost 39C temp, I am going to have another tea!

On Mac and myths:
After I ejected two instances of Keynan on the finder, I tried my luck again. The phofarsi got installed and I immediately, before I forgot, added it through keyboards with full due rights, and then. this (brace yourself):
As soon as I choose Keyman off the languages in the Language bar, a pesky screen pops up! I can write but I have to tow away the annoying screen. Certainly a new bug in macOS Catalina Version 10.15.1. I have to change the language to get rid of the pop up. It does not close. There are serious issues that I will list and expand tomorrow. Despite the bumpy ride on the Mac, seeing Keyman is a welcome sight! image

The issue of the keyboard popping up unexpectedly has been corrected and will be available in an updated version of Keyman soon (it will be available in the latest pre-release alpha version tomorrow, and the full release in about a month).

1 Like

I’ve been waiting… The moment it’s out, I’ll take it to alphabet test-vigorously! Thanks for the time and care.

5 posts were split to a new topic: Font issue with Chakma keyboard on Android 8.1

Greetings! Am I on the offside?! I want to wrap up my share for the farsiman keyboard and retest the keyboard on macOS/Win/iPadOS/Android and, perchance, the update can help.

I think the issue you reported and that I fixed will not actually impact your keyboard directly so you should be able to proceed with getting it ready for release.

Thanks, Marc
farsiman keyboard test
// Windows Pro 10 Version 10.0.18363 Build 18363
// Microsoft Word for Office 365 MSO (16.0.12228.20322) 64b
DEFAULT keys: All OK EXCEPT comma key: Must be replaced with U060C
Shift Keys: All OK
Ctrl + Alt keys: OK
Alt Keys: OK
Keyboard behaves normally

// farsiman keyboard test
// macOS Catalina Version 10.15.2
// Microsoft® Word for Mac Version 16.32 (19120802)
//right to left text direction

DEFAULT keys: All OK
Shift Keys: All OK
Ctrl + Alt keys: OK
Alt Keys: OK

Every spacebar press sends the cursor to the beginning of the line. Very annoying. Cursor is always expected to lead, to be where the next char is to be input.

// farsiman keyboard test
// Android version 7 & 9 | Tablet & Phones
// Microsoft® Word for Android ver 1.0.1 (16.0.12228.20260)
//WhatsApp* Telegram Skype [all latest for Android] ColorNote

DEFAULT keys: All OK
Shift Keys: All OK
Longpress: All OK

farsiman Help link on Android refers to farsiman Copyright info [as expected].
farsiman Help link on iPad refers to KeymanHelp; no info on farsiman.

No major problems observed.

  • WhatsApp’s Top right menu … [three vertical dots] gets disabled under farsiman; farsiman isn’t impacted otherwise.

This may be controllable in Word’s settings to make the primary text direction right-to-left. I don’t have Word for Mac here so I can’t really test.

This is not a minor issue.

  1. Apple’s own keyboard (called “Persian - QWERTY”) does not have this issue. It does not to need the direction in Word tchanged. It senses the chosen langauge, e.g .Farsi
  2. Writing Farsi (a RtL Language) on a European keyboard assumes the keyboard is L2R and only software keyboard, such as farsiman, can and should decide on the direction.
  3. The cursor jumps to the wrong end regardless of the selected direction.
    As always, thanks for your time.

Agreed, this is something we need to work on – we want to figure out how to create a per-language registration rather than the current setup we have where all keyboarsd are registered under a single language. This is on the agenda for a future version of Keyman. Once that’s in place, this issue should go away as the Farsi keyboard would be registered under the Farsi language.

And I humbly concur! And I support the efforts all the way within my narrow venu [Farsi].

A post was split to a new topic: Associating .kmp files with Keyman for Android / iOS

My first time visiting this community, was going to ask a question, the answer was sitting at the top and worked perfectly!
I had just updated a 6 year old mac book to Catalina and could not get symbols to show up when typing. Keyman looked like it was installed but it seemed like permissions were missing. This was the fix I needed!
Thank you for the great help!

1 Like

Welcome @rogerw! Glad this post was helpful. For what it’s worth, I am actively working on a new Keyman installer (may make it into the 13.0 release) which helps work through the permissions configuration and smooth the way past the various hoops and hurdles!

Hello :slight_smile: Did this ever end up getting addressed? I am supporting a MacOS user and the right-to-left keyboard I made in Keyman Developer for him to use exhibits the same behavior @Orew described above - the OS would not treat it like a right-to-left language.

Sorry to reply to an old post. Thank you!

Hi Christopher. Can you tell us what version of Keyman for Mac you are using and also what version of the OS? (I probably cannot help you, but that information will be important to someone who can.)