Fixing issues with Keyman and macOS Catalina

The latest version of Keyman has incorporated updates for macOS Catalina. We are using Catalina here, and as long as you click Allow for the prompts when Keyman requests them, it should work fine.

Download the latest version here: https://keyman.com/mac/

If you continue to run into trouble, make sure your permissions have been configured correctly in System Preferences / Security & Privacy :

  1. In Files and Folders , allow Keyman to access Documents folder.
  2. In Accessibility , allow Keyman to control your computer.

Hi, Marc! Thanks for the time.
Keyman does not show up in either Files and Folders nor in Accessibility! It has its mark in input Monitoring (checked) which has no effect for its show in the listing in the language tab.
Downloaded just to run it on the one that I had installed, if balked (in the authenticate and replace phase of dropping in the app folder) to close running Keyman, which doesn’t show in ctrl+Comm+esc listing either!
Can’t be removed either as it is lurking somewhere! Now?!

It can sometimes be difficult to update Keyman on Mac when it is in use. What we normally advise in this situation is to restart your Mac, and before using Keyman at all, upgrade it.

This post didn’t help me. :weary:
Keyman was no show in Files and Folders & in Accessibility under Security and Privacy.
As there was no reference in my Uninstall (using CleanmyMacX) I downloaded the latest from https://keyman.com/mac/ , Could not install. Rebooted and retried. Reinstall doesn’t work (keyman no show in alt+Comm+esc. In summary, I can neither uninstall nor reinstall (the newer version)

Hi Andrew. What is your mac version? Could you send me the screenshot of what popped up and blocked when you are trying to install? Thanks.

I remember when I installed Keyman for macOS Mojave 10.14.6, I have to disable or kill the process of Keyman before being able to install the new version.

To do that, open the terminal and in the baseline write: kill `pgrep Keyman` and then press Enter.

Hello, Makara!

  1. macOS Catalina Version 1O.15.1
  2. kill pgrep Keyman … I’ll get:
    MahOne:~ Andrew$ kill pgrep Keyman
    -bash: kill: pgrep: arguments must be process or job IDs
    -bash: kill: Keyman: arguments must be process or job IDs

Nothing happens on invoking the command.:upside_down_face:

I think the forum ate some of the punctuation. Try this:

kill `pgrep Keyman`

Thanks, Makara, for making Marc spot the spice! phofarsi was fed, but still, I’m jinxed. And jumping around a half dozen devices with almost 39C temp, I am going to have another tea!

On Mac and myths:
After I ejected two instances of Keynan on the finder, I tried my luck again. The phofarsi got installed and I immediately, before I forgot, added it through keyboards with full due rights, and then. this (brace yourself):
As soon as I choose Keyman off the languages in the Language bar, a pesky screen pops up! I can write but I have to tow away the annoying screen. Certainly a new bug in macOS Catalina Version 10.15.1. I have to change the language to get rid of the pop up. It does not close. There are serious issues that I will list and expand tomorrow. Despite the bumpy ride on the Mac, seeing Keyman is a welcome sight! image
image

The issue of the keyboard popping up unexpectedly has been corrected and will be available in an updated version of Keyman soon (it will be available in the latest pre-release alpha version tomorrow, and the full release in about a month).

1 Like

I’ve been waiting… The moment it’s out, I’ll take it to alphabet test-vigorously! Thanks for the time and care.

5 posts were split to a new topic: Font issue with Chakma keyboard on Android 8.1

Greetings! Am I on the offside?! I want to wrap up my share for the farsiman keyboard and retest the keyboard on macOS/Win/iPadOS/Android and, perchance, the update can help.

I think the issue you reported and that I fixed will not actually impact your keyboard directly so you should be able to proceed with getting it ready for release.

Thanks, Marc
farsiman keyboard test
// Windows Pro 10 Version 10.0.18363 Build 18363
// Microsoft Word for Office 365 MSO (16.0.12228.20322) 64b
DEFAULT keys: All OK EXCEPT comma key: Must be replaced with U060C
Shift Keys: All OK
Ctrl + Alt keys: OK
Alt Keys: OK
Keyboard behaves normally

// farsiman keyboard test
// macOS Catalina Version 10.15.2
// Microsoft® Word for Mac Version 16.32 (19120802)
//right to left text direction

DEFAULT keys: All OK
Shift Keys: All OK
Ctrl + Alt keys: OK
Alt Keys: OK

PROBLEM:
Every spacebar press sends the cursor to the beginning of the line. Very annoying. Cursor is always expected to lead, to be where the next char is to be input.

// farsiman keyboard test
// Android version 7 & 9 | Tablet & Phones
// Microsoft® Word for Android ver 1.0.1 (16.0.12228.20260)
//WhatsApp* Telegram Skype [all latest for Android] ColorNote

DEFAULT keys: All OK
Shift Keys: All OK
Longpress: All OK

farsiman Help link on Android refers to farsiman Copyright info [as expected].
farsiman Help link on iPad refers to KeymanHelp; no info on farsiman.

No major problems observed.

  • WhatsApp’s Top right menu … [three vertical dots] gets disabled under farsiman; farsiman isn’t impacted otherwise.

This may be controllable in Word’s settings to make the primary text direction right-to-left. I don’t have Word for Mac here so I can’t really test.

This is not a minor issue.

  1. Apple’s own keyboard (called “Persian - QWERTY”) does not have this issue. It does not to need the direction in Word tchanged. It senses the chosen langauge, e.g .Farsi
  2. Writing Farsi (a RtL Language) on a European keyboard assumes the keyboard is L2R and only software keyboard, such as farsiman, can and should decide on the direction.
  3. The cursor jumps to the wrong end regardless of the selected direction.
    As always, thanks for your time.

Agreed, this is something we need to work on – we want to figure out how to create a per-language registration rather than the current setup we have where all keyboarsd are registered under a single language. This is on the agenda for a future version of Keyman. Once that’s in place, this issue should go away as the Farsi keyboard would be registered under the Farsi language.