Keyman Configuration does not appear on MacOS Catalina after installation

I am having a hard time configuring my keyman application on my MacOS Catalina. I have downloaded the version that says yosmite and later so I know its not a problem of compatibility. After installation, configuration option does not appear at all even after several restarts and attempts. I have also tried to manually give keyman acess to files and folders, accessibility and Input monitoring since it didn’t prompt me at the beginning. what should i do pleasae help?

Welcome to our community, @Eman_Mohamed

Thank you for reaching out. It sounds like you did everything.

We do not have MacOS Catalina to test it out but we are able to install Keyman on Sonoma v 14.0, Big Sur, and Yosemite. Could you send us some screenshots about this issue (when it failed), version of your MacOS Catalina, and the downloaded version of Keyman?

This is a detailed instruction and a video in here - Install Keyman for MacOS and Permission
Related issue - Fixing issues with Keyman and macOS Catalina

Thank you!
Technical Support team.

I have downloaded the software many times and I’m not sure if that affects the version. However, the latest one I tried is Keyman 16.0.136.
I will send you a screenshot of the whole process i go through and my problem with it with the latest version of 16.0.144.

  1. Downloaded Keyman
  2. Followed the installation video exactly as shown.
  3. Installed and keyman chosen on the tab bar next to the battery sign.
  4. No Prompt to ask for allowance for the privacy setting → so trying to do it manually.

Thanks for the info, Eman.

For now, we suggest you keep using the version that is working as we are unable to reproduce the same problem.
However, we are able to find a similar bug report as our developers are working hard to solve this issue. We can track the progress together there.

You are welcome to file a bug report for this yourself (here) or provide us with the necessarily information to file a bug report for you, such as:

  1. A screenshot of the issue

  2. A screenshot of your Macbook information

Thank you!
Technical Support team.

1 Like

Eman, I don’t have Catalina, but I installed on El Capitan. The first time I selected Keyman as the keyboard, it came up with the prompt to set my access privileges. However, since I didn’t do it (and the window easily got covered by other windows until it timed out) it doesn’t appear any other time I select Keyman. Keyman Configuration does come up when I select it from the menu.
And, the configuration window floats on top of all other windows, so I’m not sure what the issue is there, for you.

The place you can go to activate the accessibility setting is under Security & Privacy on El Cap. They do move it around…

Finally, not sure how important this is, but it might help to select Keyman under Keyboard settings:

Good luck,


Thanks a lot, @mengheng and @JDWood, for chipping in on this.

You may also find this documentation helpful: How to configure macOS security options for Keyman.

1 Like

Due to the inactiveness of the topic, the conversation will be closed in 14 days.
You are welcome to write more if the issue still persist or create a new topic if there is any question.

This topic was automatically closed after 14 days. New replies are no longer allowed.