Keyman 13 not working with Cheyenne keyboard

One of my online students needed help with Keyman today. I helped her via Skype. She is running Windows 10. We had to uninstall the Keyman version that was not working with our Cheyenne language keyboard. We installed version 13. That did not work with the Cheyenne keyboard either. So I checked which version of Keyman I am running successfully on my own Windows 10 computer. It’s version 10. I then remembered that I had problems with all Keyman versions since version 10. So I helped my student install version 10. Everything works fine now with the Cheyenne keyboard. Can you help us be able to use more recent versions of Keyman with Windows 10?

Can you verify what keyboard you are using? What font are you using with this keyboard?

Note that keyman.com has two Cheyenne keyboards: “cheyenne” (which is an obsolete, non-Unicode keyboard) and “sil_cheyenne”.

We use the sil_cheyenne keyboard which is Unicode-compliant. We can use any standard Unicode fonts with it such as Arial, Times New Roman, etc. When we first started using Keyman many years ago someone in SIL created special fonts for Cheyenne. But we don’t use those anymore since Unicode has all the characters we need.

Wayne

Can you give us some details on the problems you are having with recent versions of Keyman? We run Keyman 13 constantly and most users are on version 12 or 13 these days, running, as far as we know, without real issues, so I’m sure the problems can be resolved.

I wish I knew what details more I could give. The only thing I remember is that versions since 10 have not worked on my computers. And I observed the same issue with my student’s computer today. I have reported these issues to the Keyman team in the past but they were never resolved. Is there any chance someone from the Keyman team could work remotely with my computer to see if the issues can be resolved?

@makara, could you work with @wleman1949 to investigate his issue with Keyman 13 on Windows 10?

I think I can reproduce the issue you’re seeing on Windows 10 with Keyman Destkop 13.0. When sil_cheyenne gets installed, Windows is assigning the language tag “ch”.

You’ll need to open Keyman Configuration --> Cheyenne --> Add language
In the dialog, search for the language code chy-latn-us
add language

Then check that Keyman Desktop has “Cheyenne” selected (might be confusing if it shows up twice)
select cheyenne

I was able to type ^a to get ȧ

Thanks, @darcy.

I have met Wayne on Skype helping him to uninstall his current version of Keyman (10.0) and install our latest version of Keyman (13.0) with a reboot in between. The keyboard seems to work when testing on a text editor.

If any other issue arises afterward, he’ll let us know and/or send us a diagnostic report.

1 Like

Darcy, you wrote: "You’ll need to open Keyman Configuration --> Cheyenne --> Add language
In the dialog, search for the language code chy-latn-us"

I am unable to locate this screen anywhere in Keyman or Windows 10. I have tried many things but I am unable to locate this screen anywhere in Keyman or Windows 10. Please give further instructions for how I can find it. I am currently prevented from doing my Cheyenne language work because neither Keyman 13 or Keyman 10 works now since Makara and I made changes to my computer. I have reinstalled Keyman 13 but I still can’t get Cheyenne characters to appear anymore. I need Keyman working to do my daily language work.

I just found this discussion on a Microsoft forum about interaction between Windows 10 and Keyman. Would something in this discussion help me get Keyman to work again with the Cheyenne keyboard and SIL language apps?

https://answers.microsoft.com/en-us/windows/forum/all/how-to-remove-the-unknown-localeqaa-latn-language/25c9aa40-656f-418b-8f50-ca767d070205

Here is more discussion about interaction between Keyman and Windows 10, especially about the qaa-Latn keyboard that shows up and is difficult to remove:

And there is more discussion about removing the Unknown Locale which is showing up on my computer:

Makara, Keyman 13 is not working now with SIL language apps. I have to use the SIL language apps in my work and I have to use Keyman for my Cheyenne language work. Please help me restore my computer so I can do my Cheyenne language work in SIL language apps using any version of Keyman. I think there is a setting somewhere which allows Keyman to work with different kinds of language but it has been so long since I changed that setting that I can’t remember where it is.

I am unable to locate this screen anywhere in Keyman or Windows 10

Here’s how to get to Keyman Configuration to add the language

Getting to Keyman Configuration

From the Keyman Desktop 13.0 splash screen, click on “Configuration”
splash

or if Desktop is already running, left-click the Keyman icon and click “Configuration…”

Installed Keyboards

Immediately after I installed sil_cheyenne, the Configuration showed:

On the “Cheyenne” row, click the up/down arrow at the end of the row (next to the question mark and “X”). This will expand the languages

@wleman1949 Please let us know whether or not the issue is resolved for you.

That discussion does not include anything that would help; hoping @makara and you have been able to resolve any remaining issues.

Thank you, Makara. I don’t know if the issue has been resolved because I have had to return to Keyman 9 (I was wrong saying I’ve been using Keyman 10). Keyman 13 does not work with SIL language apps that I use. I must be able to use these apps in my language work. They are Lexique Pro and Toolbox. I don’t know if there is an issue with Flex since I don’t use Flex, but many other linguists do. I can’t use Keyman 13 until this issue is resolved. I wish I could because the Keyman team has worked so hard to make Keyman better with each version. Thank you for all your work helping us language teams.

I’ve used Keyman 13 (the current latest version) in FLEx 8 and 9 without any issue. If you encounted any specific issue besides setting it up, do let us know. Our team are keen on getting any potential issues fixed as long as we can reproduce the issue. It is helpful to us if more details on the issue(s) can be given, and a diagnostic report is always great to have for us to dive deeper.

I do not use FLEx. But during today’s testing of a reinstallation of Keyman 13 I downloaded and tried to install FLEx 9. The installation failed. I have sent the diagnostics to the FLEx team.

With Keyman 13.0.112 on FLEx 9.0.8 RC running on Windows 10 Pro 1909, Cheyenne keyboard version 1.1.1 is working as expected without any issue of being turned of automatically (See screenshot of my test below).

The writing system requires a little set up on font and keyboard tabs.

In order for an issue to be solved, we have to be able reproduced its misbehavior. Without which, it is impossible to get anywhere from here. We appreciate that you take the time to give us all these details requires to get the issue fixed.

I have not yet tested the keyboard with Toolbox, but will do. :slight_smile:
I think most super power Toolbox has has been put into FLEx, hasn’t it?

For Lexique Pro, it looks like it is an outdated and unsupported program which may take us a bit of time to resolve this compatibility issue. Here is what our lead developer (@Marc) has to say:

[…] it [Lexique Pro] does not directly support Unicode input, and we no longer provide interfaces to support Unicode into non-Unicode applications.

More on solution and workaround on this issue can be found at:

This issue is now marked resolved.