Keyman Keyboard not staying active, & can't get rid of extra keyboard (Windows 10)

I’m sorry my screenshots are not displaying correctly. At first they did, but the filenames which described the problems, did not display. So I added descriptions before the screenshots. That caused the screenshots not to display. I will add them again here.

For the time being, you can try and use Language Switcher. To do that, Press and hold Alt and then press and release Shift to see the keyboard list on the screenshot. To cycle through the list, you have to press and release Shift x times to get to the keyboard you want to enable. Here is a link to the instructions to do just that: https://help.keyman.com/products/desktop/current-version/docs/basic_languageswitcher.

Alternatively, you can create a hotkey to easily switch to the keyboard when pressing those keys, i.e. Ctrl+Shift+C words for me. Here are instructions to configure hotkey: https://help.keyman.com/products/desktop/current-version/docs/start_hotkey_set. Make sure that the hotkey combination is not conflicted with any shortcut key of the application you are using.

For relevant into on Lexique Pro, see the last quoted paragraph at Keyman 13 not working with Cheyenne keyboard.

For Toolbox, you are right that the keyboard got switch automatically to the default preset keyboard. This issue may involve Toolbox as it does not seem to recognize the installed Keyman keyboards and currently there is no way to add any Keyman keyboard to its Language Encodings… See a bug report on this issue here: https://github.com/keymanapp/keyman/issues/3655.

The developer may need more time to investigate this and get in touch with Toolbox developer to mitigate the issues. My suggestion is that you utilize the Language Switcher and/or Hotkey.

Thank you, Makara. The issue is not being able to switch between keyboards but that Keyman 13 doesn’t stay active for some apps. We don’t need to add a language keyboard to Toolbox. Toolbox (and Lexique Pro) is unicode-compliant and works fine with Keyman keyboards except that a Keyman keyboard doesn’t stay active in Keyman 13 when switching between some apps. This is a common problem that users of Keyman have noted on various discussion forums. I have sent you links for some of these discussions. Thank you for all your help.

Actually, Keyman still stays active, but a keyboard different from what you expect is not chosen because probably no proper setup has been done. :smiley:

Both Toolbox and Lexique Pro have a Writing System (or Language) configuration where one can choose a default keyboard. I have just created a Lexique Pro project and it turned out Chayenne keyboard works after adding chy-Latn-001 keyboard to the project, even though it is marked as Unknown Locale (chy-Latn-001) and not under Keyman keyboard section. (See the screenshot below). @Marc This issue on this is logged here: Keyman keyboard is not recognized in Lexique Pro


Lexique Pro can automatically switch to the configured keyboard when jumping from one field to another.

Click to watch how the keyboards switch from Chayenne to ENG when jumping from one field to another: Keyman in Lexique Pro

As mentioned previously, Toolbox on the other hand does not even recognize any keyboard in its Language Encoding... setting at all. Only if it does, I am sure the keyboard will switch automatically when going from one field to another without having to switch it manually.

In order for a keyboard to work as expected, a little bit of set up has to be done. :smiley:

Makara, thank you for testing Keyman 13 with Toolbox and Lexique Pro. I have used these programs for about 20 years. The Cheyenne keyboard stayed active in all programs, including Toolbox and Lexique Pro, through Keyman 9. I have never had to select a keyboard in Toolbox or Lexique Pro after unicode became available. All fields in both programs continue to work fine with the Cheyenne keyboard in Keyman 9. And the Cheyenne keyboard stays active when switching between programs when using Keyman 9, but not any later versions of Keyman.

After you have configured Lexique Pro to use the Cheyenne keyboard as a default keyboard, during your testing of Keyman 13, does the Cheyenne keyboard stay active when you switch between programs, such as between Notepad and Lexique Pro? Or do you need to click on the Keyman icon to enable the Cheyenne keyboard when you change from working in Notepad to Lexique Pro?

I had some time today to dig a little deeper and review where things are at. I’m never satisfied when things are not working well for our Keyman users. I am writing this up for future readers of this as well, so please bear with me if there is reiteration of earlier content.

There are a couple of things that can cause this to happen.

  1. If you are using programs such as Toolbox and Lexique Pro that do their own internal keyboard switching, but that don’t support recent versions of Keyman, then they may switch away from a Keyman keyboard. In my testing with Lexique Pro, it should be possible to configure it to select a Windows language which has a Keyman keyboard, and it will switch appropriately. But this is not possible with Toolbox.

  2. In Windows 8, Microsoft introduced support for keeping the same keyboard layout active across all applications. In recent builds of Windows 10, control for this can be found by searching for “Advanced Keyboard Settings” in the Settings app, and ensuring that the option “Let me use a different input method for each app window” is deselected.



Keyman had its own “select keyboard layout for all applications” feature which is available in Windows 7. In Windows 8 and later, this would understandably interfere with the Windows implementation, so it is disabled when running on Windows 8 and subsequent versions.

The irony is that as recent versions of Windows have made it possible for Keyman keyboards to be treated identically to Windows keyboards, improving compatibility with the majority of applications, some programs such as Toolbox, which had deeper support for keyboard switching for many years, got left behind. Toolbox looks for keyboard layouts rather than Windows languages – and does not recognise modern keyboard layouts such as Keyman, or the Windows Amharic keyboard, or many others.

So long as the Windows language setting “Let me use a different input method for each app window”, as I described above, is deselected appropriately, with Keyman 13, I do not need to manually switch keyboards when switching apps; the Keyman keyboard stays active until I switch it (or Toolbox or Lexique Pro switch it).

Where to from here

I guess you’ll have to make a trade off decision.

Keyman 9

If you need to use Toolbox, you may find you that older versions of Keyman offer better compatibility for your needs. You may need to work with the M and O key issue (more detail on why this happens here). Two things you can do to mitigate this:

  1. Disable the Alt+Shift+O and Alt+Shift+M hotkeys in Keyman Configuration
  2. If the problem arises, press and release each of the modifier (ctrl / shift / alt) keys to reset the global modifier key state. You may need to press the keys on each side of the keyboard.

Keyman 13

Alternatively, you can use Keyman 13, and configure hotkeys to switch between keyboards when using Toolbox. Lexique Pro should switch keyboards appropriately.

1 Like

Thank you, Marc. I think I must continue to use Keyman 9. I have 40 years of work invested in SFM-formatted databases to change to a more recent program like FLEx. FLEx consultants and I spent a lot of time trying to get FLEx to work with Cheyenne data. There is no way to convert Toolbox interlinearizing rules to work in FLEx. I’m 70 years old already and it would take several more years to convert the rules manually. But we’re on the last year of a three-year grant so we just need to keep plowing ahead with what works. I’m not happy with Windows 10 but can’t do anything about it. There are a good number of Cheyennes who used the Cheyenne keyboard with Keyman. I help them remotely to install Keyman and troubleshoot it when something doesn’t work. So far, Keyman 13 has failed for them under Windows 10 even though they are only using Keyman with compatible programs like Microsoft Word. I don’t know why. I can’t figure out it remotely.

I will file your good instructions in case I have time someday to experiment more with Keyman 13. I very much appreciate all the time you, Makara, and others on the Keyman team have spent trying to fix the compatibility issues.

2 Likes

We would like to know more about what does not work when using Keyman on Microsoft Word. I do not mind to do live support for them if that helps.

Makara, thank you for being willing to work with my student remotely. I don’t think she would want to do this. Keyman 10 is working for her now and she is satisfied with that.

@Marc, yesterday my computer started doing weird things. I rebooted it several times but it kept acting weird. So I reinstalled Keyman 13. I followed your clear directions to choose the Cheyenne default keyboard.in Lexique Pro. Lexiq ue Pro works now as you said it should. The olnly weird thing remaining is that my Bakckspace key no longer works when I’m using the Cheyenne keyboard. As soon as I turn off my Cheyenne keyboard the Backspace key works again. YPerhaps you can see evidence of the problem in this messages, where I have tried to fix my typos. Have a good week, Wayne (Later: (It appears that the Backspace key no longer works when using the Cheyenne keyboard in any version of Keyman, including 13, 12, and 9. // Yet later: the problem with the Backspace key only occurs when using the Cheyenne keyboard and Google Chrome and Moicrosoft Edge, which uses the Chromium engine. Firefox works fine. And the problem only occurs, so far, on my desktop computer, not my Windows 10 laptop.

I’ll try to troubvleshoot and fix this issue since Chrome and Edge are the two browsers I most often use. // Here is a link about this (or a closely related) issue on both browsers: https://www.thewindowsclub.com/enable-backspace-edge-chrome The Chrome Backspace key extension does not solve the issue with the Cheyenne keyboard: https://chrome.google.com/webstore/detail/go-back-with-backspace/eekailopagacbcdloonjhbiecobagjci?hl=en)

My backspace just stopped working too!!!

Sorry to hear that, Alex. Did your backspace stop working in all apps (or just the Chrome or Edge browsers)? Does it happen only when you have a certain keyboard enabled in Keyman?

Well, that’s really weird. If you are able to send a diagnostic report through (follow steps at https://help.keyman.com/knowledge-base/40) that’ll help.

Can you clarify the circumstances in which the problem arises:

  • is the problem with all apps or specific apps?
  • does it happen only when a Keyman keyboard is active?

Finally, if you can reproduce the problem reliably, send me a debug log via PM on this forum (https://help.keyman.com/knowledge-base/76), so I can trace the issue as it happens.

@Marc, I’m not sure if your questions are for Alex or me. I gave a longer reply to you with all the details you requested at this link:

@Marc, I’m not sure if your questions are for Alex or me. I gave a longer reply to you with all the details you requested at this link:


If’m not sure how to get a correct link to display in this forum, so if that’s not the correct link, my reply is just before Alex’s ceomment. Sorry about the typos. They are due to the new issue with the backspace key which no longer works when my Cheyenne keyboard is nenabled.

@Marc

  1. Backspace no longer works for me when using Goodgle Chrome or Micorsoft Edge browsers.
  2. It happens only when a Keyman keyboard is active.
  3. It does not happen with Firefix.
  4. It does not happen on my laptop which is also running Windows 10.
  5. It happens now with all versiions of Keyman that I hafve tested it with, 9, 10, and 13.

Hi @wleman1949,

Thanks for the quick reply. I have now reproduced this issue. It appears that this is a problem introduced by the latest release of Chrome (86.0) – the same code is also used by Edge. When I tested on my machine earlier this morning, I was on version 85.0, and it was fine.

Given that this is a clear regression in Chrome, I will be following up with a Chrome bug report as a first step.

1 Like

Thanks, @Marc. The issue started for me yesterday. Have a good week, Wayne

We are tracking this backspace issue at Backspace, Chrome 86 and Keyman

Please do go through and vote for the Chromium issue if this impacts you!