WebView2 not updating (with fix)

SIL Tools have long depended on packages like .NET or SQL that users would have to install and upgrade (and sometimes upgrade their OS) before using our software. Fieldworks kicked SQL though both Paratext and FLEx still depend on .NET (Which limits those apps to Win 10 and 11 after 2019). I understand why we use these plugins instead of reinventing the wheel.

It’s been nice to grab a version of Bloom and it just worked (as long as you had a PDF reader from this decade). We’ve spent the last little while trying to install Bloom Beta on a new machine, and it’s requiring Edge’s WebView 112. Bloom Beta requires WebView 112+. The machine has WebView 90 (with no uninstall option under programs and features) and the online installer for WebView won’t upgrade because it says it’s already up to date (BloomBeta complains that we only have 90). I’m now downloading the offline x64 installer for WV120 which weighs in at 164 MB. It seems like a headache to start to require a new large runtime that no one is likely to have on their machine.

FLEx and Paratext have always demanded admin rights to install, but Bloom didn’t. Requiring this WebView runtime now means that Bloom cannot be installed without Admin rights on the machine, which is a step backwards for the user. Is this a temporary dependency, will Microsoft roll it into Windows updates, or will we have to continue installing/upgrading this on future machines?

Hi Mathew,

will Microsoft roll it into Windows updates

Yes, WebView2 is automatically maintained by Windows if the machine is getting updates. We could create installers that included WV2, but then the installer would just be that much larger to download.

PS: For what it’s worth since we’re no longer bundling the now-obsolete geckofx web engine, Bloom installers are now 30MB smaller than before.

1 Like

I don’t use Edge, but I’m pretty sure WebView versioning blocked me, and I’m on Win 11 22H2 (the last update available for this machine).

So, to run the beta requiring WV 112, the computer needs to be updated beyond May 2023. I guess that’s OK for beta testers.


What version of WV is needed for the stable version?

Fieldworks and PTX’s .NET only requires .NET updates to 2019 last I checked, but we’ve still been having to upgrade Windows on a large percentage of user machines that have come in here over the last years to keep PT 9.2+ running.

If you did bundle WV, the BLOOM+WV2 would require admin permissions (for the WV part), correct?

The machine we were working on has a 2021 version of Windows 11, which isn’t new enough.

112 is our minimum version for now. We have no current plans to increase the minimum.

If you did bundle WV, the BLOOM+WV2 would require admin permissions (for the WV part), correct?

I wouldn’t think so, but we haven’t tried. The embedded WV2 would only be available to Bloom.

Yeah…until WV 112+ is more common in the wild, it might be nice to offer a larger “offline installer” like FLEx and PTX rather than going on a Microsoft Easter Egg hunt…

Can you point me to a standalone Microsoft KB update file that I can install on Windows 11 if online updates are not available?
The machine has Win 11 22H2 (latest version, no TPM) which comes with Webview 90. and will never get automatic updates. Trying to install Webview from the middle option below, it refuses to install 120+ because it thinks that 90 is more recent.

We don’t have one on hand, specifically. (In other words, I’d just be Googling, too.)

But you could take a look at WebView2 Trouble | Bloom Docs.
Option 3 could potentially be relevant.
Or the nuclear option 4 could be a stop gap for you.

So, after nearly a month…we have a breakthrough. If you’re not getting (daily) Windows updates, upgrading to 22H2 is not enough, that still leaves you with WV 90. The machine was updated to 22h2, and we had the problems described above where Webview was too low a version, but the WebView installer would refuse to upgrade. Eventually, he opened Edge, which he doesn’t use, and it decided to update itself (without going through Windows Update). It seems that the version of WV is tied to the version of Edge. It doesn’t want to update the system version beyond the version of Edge.

  1. Upgrade Windows to the most recent version you can (22H2 in this case).

  2. Verify that there are no leftover versions of Bloom/BloomBeta/BloomAlpha in appdata.

  3. Open Edge, and let it update/force an update to something recent (>120) (you way need to allow it to update over a metered connection.

  4. Install Bloom.

1 Like

Hey Matthew, I’m glad you got that machine updating! A few questions:

  1. Is this machine using the “nuclear option” Andrew pointed you to, of using Edge directly?

  2. Was it necessary to remove existing Blooms and re-installing Bloom afterward? I can’t think of why either of those would make any difference. Bloom doesn’t do any hooking up to anything during installation, it just checks for WebView2 each time it runs.


No, we didn’t change any config. This was just fighting to get the prereqs before installing Bloom. An outdated Edge with embedded WV was the problem. Edge had the outdated version of WV until forcing the upgrade, so I’m not sure how the nuclear option would’ve helped (it still wouldn’t be fully compatible).

I can’t remember if the fatal WV error was on install or at runtime. (My intern was doing the investigation).

We had to wipe old Bloom versions because the stable installer had been silently closing prematurely and failing to install anything. We uninstalled what we could see from Control Panel and then deleted an oddly remaining BloomBeta folder (even after uninstalling), then the install finally went through and loaded Bloom without error.

OK thanks Matthew. We know that WebView2 is not involved in Bloom installs. I’ve added the idea of updating Edge to the troubleshooting docs.

Here is the link for a .log file on the error. Hope it can help.

[InquirrelSetup Log file] (SquirrelSetup.log - Google Drive)

I see that updating Edge is now in the docs, but we didn’t have to update variables or “do the nuclear option”. Maybe they should be separate steps.

I have a user here in Chad who has this WebView problem. They have Windows 10 Pro, and when I tried to update Edge, it said that updates are managed by your organization. (That’s why I don’t like Pro versions of Windows…) The version of Edge seemed to be pretty recent (118, I think?), but Webview was something like 89 or 90. I checked out the steps Andrew suggested at WebView2 Trouble | Bloom Docs, but none of the first 3 steps helped - the third step didn’t work I assume because of this management issue (Modify spun a bit but didn’t do anything).

The user is leaving for the village tomorrow, so we installed an earlier version of Bloom (5.2 or 5.3, I think), which works fine.

One more case (Windows Pro - can’t update webview) where the switch to this platform is causing pain.

Hi Jeff,

Shots in the dark here: If the Microsoft user account is not @sil.org or something similar, the “managed by organization” error might be an error/virus or something or be related to an inappropriate/volume license for Windows. Can you try this to unlock Edge?

If that works, you should be able to update Edge from the inside, but you may have to do that from an unfiltered connection.

If your Edge is that far up to date, I would think that the Nuclear Option 4 (which I haven’t tried) should work.

Hi Jeff,
Since the user’s Edge is > our minimum of 112, you should be able to use step 4 of the trouble shooting docs.

Thanks for the feedback. The person is just happy with having the older version for now (and is preparing for travel tomorrow), so we’ll maybe look into this the next time they are in town.

For future readers of this thread:
5.5 is the first version of Bloom which would have this problem.