Verse Notification & App not responding

Greetings worldwide teammates, in the last few years I have built and launched a few apps without the following issues so far. But I have 2 right now. Please see attached screenshots

  1. A popup for Notification Permission and Verse daily reminder appears ONCE after installing app first time, even though I did not check them on in the builder settings NOTIFICATIONS > DAILY REMINDER > 2 checkboxes. This is an issue because a)our app is about folk stories- nothing to do with bible verses b) the notification is in English.

  2. A more serious issue is that a popup that says app isn’t responding. I tried the following steps but it is still does not solve the issue.

  • update RAB to latest version 11.1.1 (target API 33 as required by Google PlayStore)
  • with and without audio
  • different minimum platforms (API 29-API 33)
  • two different Android phones (Android 11 and Android 13)
  • waiting and not swiping the app or playing audio after it launches
  • *note - audio is incl. in APK. But it is also an issue without audio.

However, I observed that this problem seems to come and go. Sometimes it does not appear, sometimes it appears, sometimes it appears when I start swiping, sometimes it disappears after I open and close app a few times, sometimes it works after pressing ‘Wait’ a few times.

So far i have tested the App by installing the APK directly NOT from Play Store yet. Could this be an issue? Maybe I should roll it out on Developer Console, download from Play Store and test it?

My test phones are on developer settings too.

I don’t know if this is link to the earlier Notification Permission?

Thank you and appreciate your help fellow workers!

Hi all,

the Verse Notification issue is solved.

But the App ‘Not Responding’ popup is still an issue. I am testing on two phones Android 11 and 13. Both have similar symptoms.

Every time App restarts, the popup sometimes appears and sometimes does not.
Sometimes popup disappears after a few taps on ‘Wait’, sometimes after one tap.

This issue happens even without touching the App after restart (No swiping or clicking audio)