"Use this text" field not showing up in app

When I specify a different name to show in the space bar area of each of the 3 keyboards included in the app I am building (names not shown in image), and build the app, none of the names I specified show up as expected in the space bar area.
I am using KAB 11.0.4. I didn’t have this problem in the previous version of KAB I was using (sorry, I can’t remember exactly the version, I think 10.x??).
Thanks for any help you can give.

Would you mind creating an issue ticket here?

First I wanted to add a quick +1 for my Keyboard App Builder version 11.1

Then I wanted to go to the Support site and see if a ticket has really been filed yet, since @kklcclkk never replied.

I did sign up on the Support site as a new user and got a green bar with “succesful registration”. But I never received any mail or other confirmation with PW. So I cannot log in. When I try to register again, I get a message that this e-mail is already in use. When I try to use “forgot pw” I am told that I do not have any rights to access. Seems I am stuck in a half-finished sign-up process?

Just to be sure, I tried all over again with another mail address and got the same symptoms. So @AndrewS if you are on the Support team or you can contact them, please let them know, so that they can test their onboarding system.

And back to the issue here: Seems to me that the keyboard package coming from Keyman is forcing the label on the space-bar and that KAB somehow cannot overide it. Seems Keyman is using the (internal) project name to put on the space-bar and that would be unsuitable for our end-users. I do not want to use “nothing” as a Keyman project name, because that might crash.

So any ideas for a work-around anybody? I have a deadline early next week, to prepare a Google Play keyboard-launch to a large international audience in context of an important local cultural gathering.

My apologies, Martin, for my lack of reply. I did create a ticket, and they said it is in the queue. It didn’t sound to me like it will be ready for your deadline, as they didn’t give any date for working on it.
I am not sure whether it would be feasible to revert to a previous version of KAB that didn’t have this bug for your launch or not, but if it is, that is the only solution I can think of for the short-term.

I experimented a little (with pressure from my deadline) and I found this:

KAB is offering four options, for what to put on the space bar:

  • keyboard name
  • language name
  • use a custom text
  • leave space bar blank

Today by accident I found that opting for “leave blank” actually puts the language name on the space bar! So possibly the App Builder just got some internal reference-pointer a little off (counting from zero versus counting from 1, or something like that).

I do not have enough time to try all possible combinations, but I am happy for now, can release my app without some internal “project name” on the keyboard.

1 Like

This work-around doesn’t seem to work in 11.0.4, so I will update to 11.1 and try it. I am so glad you found a way to make it work in time for your launch!

Now I tried it with KAB 11.1.1 and when opting for “leave blank”, I still get the same result of having with the keyboard name and language name on the space bar (too cluttered).