Updates available - repeats

When I run the Keyman Android app (version 13.0.6220), it quite frequently gives me this message:

Resource Updates Avaiable
Updates available for dictionary
en: English language model mined from MTNT
Would you like to download the latest version of this dictionary?

I tap Download, it says the download was started in the background, and then says the download finished, sometimes after a little while and sometimes immediately.

But then a while later, or next time I start up the app, I get the same message.

I have EuroLatn installed, with that MTNT lexical mode installed. It says version 0.1.4 (Update Available), but no amount of updating seems to change that.

So I tried deleting the model, which I did and now don’t get the message anymore, but I also don’t have an English model with my keyboard, and don’t know how to get that back. I can’t seem to delete the EuroLatn keyboard like I can delete the keyboards I’ve added later, to try to start from scratch.

Any advice?

The easiest way is to uninstall and then reinstall Keyman for Android. EuroLatin is Keyman’s default keyboard which can’t be uninstalled.

What is your Android version? I do not experience the same this on Android 10.

You can download version 0.1.5 of the MTNT lexical model at

Once the kmp file is saved on your phone, there’s a Keyman settings to browse and install the kmp file.

I’m on Android 10, and if I uninstall the Keyman app, and re-install from scratch, I just have the one keyboard, EuroLatn (SIL). Right from the start it gives me the “Install Updates” option. If I go look at the MTNT dictionary options, it says version 0.1.4 (Update Available). But using the download link there, or anywhere else I have found produced the same result. It says it is downloading, and tells me it is finished, but the version never changes.

I have now downloaded 0.1.5 of the MTNT lexical model with Darcy’s link, and installed it. But even then it took a little while for the “Install Updates” option to go away.

This isn’t a big deal for me personally, but I’m concerned about the general user experience, if it keeps telling you there is an update, but it never seems to perform the update.