Unable to deploy Keyman with MECM and Intune

Hi,

I have already opened a ticket a few years ago and it was working in MECM for a while but it stopped and now the problem is persisting.

I have over 5 000 devices that I need to install Keyman on using MECM and Intune.
The installation will either not happen or it does install and the keyboards are either not there or not activated.

I’ve also had many complaints of the font changing when they type.

Is there anyone who can help me fix this?

Hello @Natcay,
We will try and help you fix this. Marc who helped you last time is unavailable for the rest of the week. However, if you can provide more details that would be useful.
Is there a script that is run via MECM to install Keyman?
What command line parameters are passed with the installer?
What are the keyboards that are being installed?
What version of Keyman is being installed?
What version or windows are you deploying to?
Thank you,

I am in meetings and travelling, then on leave, until 26 Sep. I will come back to this when I am back in the office. As @ross notes, some more data would be helpful. Also critical for me to be able to assist are logfiles, error messages, diagnostics, screenshots of what you see, and Keyman diagnostic report from a client machine (https://help.keyman.com/kb/40)

Also would be good to split the two issues into separate conversations. @ross may be able to assist you with the second issue.

Hi Ross,

There is no script that is being pushed via MECM to install Keyman. We had one that was being pushed via GPO to activate the keyboards but it wasn’t working properly and it was deactivated.

This is the command line I have for the installation: setup.exe -o -s

I’m trying to install the is the BJCreeUNI (east). It has two supported languages.

Right now I am trying to install the latest which I think is 16.0.141

The Windows version installed is Windows 10 but it varies between 21H1 and 22H2.

@Natcay, we still need at least some of the following to be able to help you:

Also would be good to split the two issues into separate conversations.

Can you start a new topic regarding the “font changing when they type” issue?

So whenever I try to deploy it I get this error code. I tested another app deployment to see if I got the same error and I don’t. Only Keyman does this.

I’ll look for the logs from MECM

Once you give us the logs I will have a look. Then we will probably need to organise a call so we can walk through the setup.

Here are the logs on the client device I found when trying to deploy Keyman


please attach log files as text, not images – it’s very hard to work with images.

A quick look suggests that the machine context does not have read access to the path on your share drive \cscree.local\mem\Sources\Applications\Keyman\16.0.141. I don’t know why that would be – but it doesn’t look like a problem with the Keyman install image if the machine can’t even read the .msi file.

I’m not sure it is the access that is the problem. I have tried different version of Keyman which means different paths and they all gave me the same result when I deploy them.
I don’t have that problem for other applications. Only Keyman.

Here are the logs in txt format.

Keyman log.zip (31.9 KB)

1 Like

The log is definitely saying that the machine context cannot access the share drive – perhaps because you are launching the Keyman installer elevated (it needs to elevate to complete installation anyway because input methods in Windows must be installed in machine context, not user context).

One thing you can try is to run an Administrator command prompt, and see if you can access \\cscree.local\mem\Sources\Applications\Keyman\16.0.141 from that elevated command prompt? If you can’t, then that’s likely the source issue.

Is it possible to copy the installer into a temporary folder on the local computer before launching the setup.exe installer? That would workaround the issue because the elevated token would then not need network access to run setup.exe.

Thank you – much appreciated!