Turn off hint for one key

On the touch layout code view it has “defaultHint”: “longpress”. This seems to make it impossible to change a hint or remove a hint. Is there another value I can use for defaultHint?

Good question. I had to test it myself to make my answer was right. So I setup a keyboard with a longpress default hint:


Which then showed the following in the Hint box:


But you can override the default just by clicking in the box and typing something else, e.g. a space would ‘remove’ the hint, or any other text would replace it:


Note: the field isn’t disabled – a disabled field has a grey background, e.g.:


Great, thanks! I thought the hint field was disabled, it was grey and when I clicked I didn’t see a cursor. Good to know I can just type into it.
Where did you go to get that dialog that shows the Default hint source?

That dialog is the Platform settings dialog.

Gotcha. I clicked the Edit button under the platform section and saw that. Thanks!

Also, note the difference in the font colors there:





Note how the hint set as the default has gray text (faded) instead of the full-black text for the custom-tailored hint. This is meant as a visual cue.

This topic was automatically closed after 13 days. New replies are no longer allowed.