SIL Eurolatin via ibus on linux - why does it force US layout? Can I change this?

Hello, I’ve recently migrated from an old kmfl install, given that the download link for the old eurolatin .kmn file no longer works. I’m using the keyboard via ibus. As a tangent, I wonder because of the process of having to go into keyman and clicking install, if there isn’t a way one could script this? I ask because there is an AUR package for kmfl-eurolatin (which naturally doesn’t work now the download link is down), and I would be interested in providing a similar package or making it easier for the original maintainer to do so.

Anyway, back to topic - what I expected to happen, was that I would tell ibus to use it, and I would type, and the diacritics would work, and that it would keep my keyboard layout as-is. This was the case with the old eurolatin kmfl. Instead, it changes it to US layout.

Is there a way of modifying this (either in a file or by keyman itself), of making multiple variants, or so on?

Thanks for any help you can give me.

Nevermind - there is an option in ibus to respect system keyboard layout!

Sorry for the noise - I can delete the post if you want, but if I missed it, someone else probably will.

It’s useful information, thank you for sharing your solution!

Yes, you can install using km-package-install:

km-package-install -p sil_euro_latin

The -p parameter searches the online catalog and downloads and install the matching file.

Good to know - I will look into packaging something for the AUR when I have time.

I have discovered, though, that my problem isn’t solved - ibus is using a ‘system’ layout, but it is not the same layout as the UK keyboard still. I didn’t notice until I went to type \ to make ð and @ for an email.

I’m not really sure where to look, I will try to find out where ibus finds this ‘system’ layout, maybe it is different somehow… My xorg layout is definitely set to UK, checked via setxkbmap -query | grep layout, and my default locale layout is also set to uk, checked via localectl status.

Okay, I am not sure; @darcy or @EberhardBeilharz might be able to comment. I will note that there are likely to be some interesting edge cases; Keyman Desktop (Windows) has a feature called “mnemonic layouts” which attempts to smooth the way for different European layouts, but Keyman for Linux currently does not have full support for that, and until it does, it’s likely that we’ll continue to see things are not quite right.

Yes, mnemonic keyboards don’t currently work properly on Linux. I created issue #3345 to track that task.

Sorry for the late reply, and thank you for letting me know. I’ll keep an eye on it :slight_smile: