SFM import to FLEx is broken

I had a terrible experience importing SFM databases into FLEx recently, and today, I learned that it keeps happening. Essentially, SFM import worked for entries but there was a terrible mismatch between the LWC of the country and the other glosses. They were off by one or two entries. And, it happened consistently. What’s worse, is that it was 200-300 entries at a time. So you can imagine the frustration of importing hundreds of words, only to find that you haven’t gained anything over manual input.

Members of the [FLEx list|https://groups.google.com/g/flex-list] might be quicker to respond to FLEx-related queries.

A few questions to understand what’s happening:
How many data sets have you tried importing?
What was the source of the SFM files? Have any been hand-edited?
You mention that glosses were off by “one or two” entries. Were any glosses on the correct entry? Did the number of shifts correlate to the entry’s position in the SFM files?

If the shifted entries are in groups, do you notice any patterns in the entries at which the shift starts, or changes? Specifically, backslashes would be most likely to cause problems if FLEx doesn’t recognise how they’re escaped. Or any nonalphanumeric character or diacritic that is common or unique to entries at shift points could be a clue to what is happening.

If you wouldn’t mind sharing your data with flex_errors at sil dot org, someone could help you look.

It may be helpful to use SOLID (Home - Solid - Solid) to check the data before importing to FLEx.