SayMore now wants short names?


I’ve just updated to 3.5.2 after a year of Home Assignment. Now, every time I open SayMore, I get a series of these notifications (seems to be one for every .wav file in my project). I’m not smart enough to run the fsutil 8dot3name utility…what else can I do to fix this?

SayMore has always used third-party utilities that rely on short names. We added this message to help users become aware of this requirement in (relatively rare) situations where they are using SayMore to store data on a volume that is not configured to provide short “8.3” filenames. It’s possible that in your particular situation, the utility is managing to work with the longer name (which would then mean that the message is a bit unfortunate), but I think the best thing would indeed be to try to run fsutil. If you have an administrator account on your computer, it might not be as hard as you think.
First, shut down any applications that might be accessing the D: drive (preferably all applications) and close any Windows Explorer windows
Then do the following (The first three steps correspond to the red-numbered steps 1-3 in the attached screenshot.):

  1. In the Windows search box, type cmd
  2. At the top of the list of matches, you will see Command Prompt App. Right click that.
  3. Select Run as Administrator.
  4. If prompted, enter your Windows administrator credentials or click the button to confirm that you want to run Command Prompt as an administrator.
  5. At the command line, type fsutil 8dot3name set d: 0 and press ENTER.
  6. After confirming that the command completed without any errors, you can close the Command Prompt window.
    If all goes well, your problem should be resolved in SayMore.
    If you don’t have admin access, then you would need an administrator to do the above for you.

Please feel free to contact me directly at if you need further assistance.

Thanks so much @TomB for getting me started! That worked, but there was one more step I needed to do. Apparently, “Short filenames are only created when files are created, copied or moved. Enabling short filenames won’t cause Windows to scan the drive adding short filenames to all files that don’t have them.” (gleaned from this thread) So I moved my project file to another directory and back, and now all is well. Thanks again!

Good work! Sorry I didn’t realize that the files would have to be copied like that to force creation of short file names. I see that fsutil does have an option to set the short name, but it apparently has to be run for each folder or file one at a time, and you have to specify what the short name should be, so that’s a pain. I poked around to see if I could find any existing utility that could do this in more of a batch mode, but (surprisingly) no one seems to have created such a tool. It doesn’t seem like it would be too difficult.

Thanks to both of you, that fix resolved my issue as well. Let me add that at least for me, I needed to move the files not only to a different directory but to a different drive (C:) and copy it back to D: for it to work.