Rtl switches to ltr with punctuation

Recent versions of Keyman handle punctuation like quotation marks, commas and full stops as ltr even if in an rtl font and setting.

I’ve noticed that this happens only at the end of a paragraph which is where you usually are when typing something new. But if I first type some characters to trail where I’m actually typing, the problem is resolved.

To make sure we can easily reproduce the problem in case it depends on specific keyboards, etc:

What sort of device are you using Keyman on? Windows, macOS, Android, iOS, or Linux?

What keyboard(s) were you using at the time?

I am using Windows 10 and the keyboard name is “Yiddish/Hebrew”. I also want to add to the problem that it’s not just end of paragraph that creates the problem but any combination of more than one punctuation or a punctuation followed by a space it will jump to ltr. However, a punctuation followed by a character seems to be fine

I have raised an issue for this problem here.

1 Like

The display problem is that the “text area” or “paragraph section” is set as LTR instead of RTL.
By correcting the setting in Notepad, LibreOffice and Word the punctuation behaves correctly.
For Word you can change this setting using the Paragraph ribbon and selecting the “<” as shown.
Screenshot 2023-10-31 124427
The setting in LibreOffice is an identical icon.
For Notepad you can right click in the main display area and select “Right to left Reading order”

It is also worth checking the correct language is registered for the keyboard. You can do this with the Keyman Configuration.

1 Like

Thank you.

I am aware of the paragraph direction icon in Word and Keyman works fine in Word. However, my bug report was for OneNote. There are (or were) two versions of OneNote, one that came with (or could be downloaded for) Windows10 and another version that came with the Office suite. Keyman didn’t used to work in the Windows OneNote but worked fine in the Office OneNote where I’ve used it happily for many years. It still works but with the bug that I reported. OneNote also has the paragraph direction icon you mention, but it works only for characters and not for punctuation as I reported.

I’m using OneNote in Office365.

I just tested against
Microsoft® OneNote® for Microsoft 365 MSO (Version 2309 Build 16.0.16827.20166) 64-bit
I found using the short cut ctrl+RShift (which should be the same as the icon) worked well. Use ctrl+LShift to switch back.
I also tested Windows 10 app version
Version 16001.14326.21452.0
It also worked fine with the same keyboard shortcut to switch to RTL

1 Like

I tested it both on my work and home pcs with the same result. This is a recent problem as I’ve used this for a very long time without a problem.

Here’s a screenshot of my kb. Is there any way I can upload the kb file so you can try?


Yes, you can send a private message with the keyboard kmp so we can try it. From the screenshot, I can see that you are using an older version of Keyman. That being the case do you know which version number of OneNote it was working on? Or roughly what month it stopped working?

Sorry, that was my work pc with older version of keyman. Below is a screenshot of home pc with current Keyman version.

OneNote version is: Microsoft® OneNote® for Microsoft 365 MSO (Version 2309 Build 16.0.16827.20166) 32-bit.

Where would I find the kmx file below? I can only find a similar named kmp file. It won’t let me upload as I’m a new user and here’s a dropbox link.


You also asked me when the bug developed. Difficult to say. Perhaps last 6 months to a year. Around the same time, I also got other bugs where when switching to a keyman language either it kept typing English or nothing showed up. Restarting Keyman or the pc usually resolves that. Sometimes there’s also an indent of a single character at start of line. These occur only in OneNote and only with the Keyman language.

For eg. typing now, I can type with Keyman in Word or in this box here but when I go to OneNote it won’t work in a new paragraph. But if I go to an existing paragraph it all works fine. And if I start a new paragraph and switch out of the Keyman language it woks fine again.

Thank you for sending that through. The kmp is the correct file needed to install the keyboard it is a package file and contains the kmx file you can see in the configuration menu. This behaved fine for me. The only difference between our versions of OneNote is that I am on 64-bit build. I am out of ideas of what to try for your system.

As a side note the keyboard you sent through is actually deprecated and has been replaced by Yiddish Pasekh keyboard (keyman.com). Unless you have a good reason to keep using the one you have it is recommend to uninstall it and install its replacement at the link provided.

You are right and this wasn’t in fact the keyboard I’m using and sorry for the confusion. I’m aware of the Yiddish Pasekh kb but it’s a transliterated kb whereas the one I use is the standard Hebrew kb with shift keys for vowel symbols. From my searches there is no other like it!

The kb I have is from an old package with an early version of keyman. The installation process asks first for installation of the Yiddish keyboards and then for installing keyman and so I skip the second stage. I can’t extract the kmp file from it but you may be more adept at that than me.

Here’s the link: https://1drv.ms/u/s!AiRwSjpWGEfjgYpZ7vSH5wD7Mv69IQ?e=jvuU5F

Thanks again!

That keyboard also works for on my system. Something with your OneNote is not quite right. I think you could try turning on TextServicesFramework integration just for OneNote to see if it works better with punctuation on your system.

To do this open Keyman Configuration and Choose the Options tab on the left, then scroll down to the bottom and select the Keyman System Settings... button.

On the windows that appears now select(click once) the row that says engine.compatibility.text_services_framework. Then press then click the button on the bottom left Add TSF Override.... Type ONENOTE.EXE in the Filename: field and select 0 - Disabled in the Value: field. Select OK and then Apply.

Restart Keyman and OneNote

Give this a try.

Yippee! It works a dream and thanks a mil. I can’t believe that I have it back.

BTW, is it possible to make this a Yiddish font for general distribution like Yiddish Pasakh? The advantage of this font is that it generally works like a standard Hebrew keyboard unless you hit shift.

Thanks again.

Glad you have a working solution.

As for making a general distribution, I believe we need the permission of the authour. Looking at the help file it is the same author as the Yiddish Pasekh. I will see if we have a contact for them, we might be able to have it available if they agree.

This conversation has been resolved.

This topic was automatically closed after 14 days. New replies are no longer allowed.