Problem with Keyman keyboard Windows 11

I’ve recently upgraded to a new computer with Windows 11. (Was previously using Windows 10.) In the process, I’ve moved from Fieldworks 8 to Fieldworks 9. No problems with that. Then I needed to install Keyman ( I used IPA Unicode 5.1 (ver1.2) KMN). In Windows 10 I had it installed as the keyboard for my default input methodː English (New Zealand). In Windows 11, I’ve added it as an additional keyboard, alongside the NZ Aotearoa keyboard, inside English (New Zealand). These two keyboards both show up in my input methods, and I can get Fieldworks to talk to them. I also have a Chinese keyboard for inputting in Chinese, but this is separate from the two keyboards in English.

However, some of the input keys are not working according to the IPA Unicode 5.1 (ver1.2) document.

These ones are good:
ʈ ɖ ɭ ɳ ŋ ɲ tʰ kʰ ɑ ɕ ʑ ɯ ɤ ɪ æ

These ones are notː
a| gives ã instead of the expected open central unrounded vowel
z| gives z̃ instead of the expected unrounded alveolar apical
y| gives ỹ instead of the expected rounded alveolar apical
n| gives ñ instead of the expected front-palatal voiced nasal
R^ gives R^ instead of the expected upside down R “affricated” symbol

There are also multiple issues with diacritics and tone marks. Can anyone help, please?

Welcome to the community @Meigui,

I’m sorry that you can’t use the IPA Unicode 5.1 (ver 1.2) KMN Keyboard. I have tested this keyboard on Windows 11 Home Single Language with Keyman v16.0.144 and it works as expected.

  • a| output α
  • z| output ɿ
  • y| output ʮ
  • n| output ȵ

However, R^ still output R^ because there’s no rule exist for this consonant. If you want upside down R (ʁ), you can try R>.

(ref: IPA Unicode 5.1 (ver 1.2) KMN Document)

Can you tell me which version of Keyman you’re using? Is the keyboard not working everywhere on your computer? I’ll try to reproduce this issue.

I recommend using the latest version of this keyboard which you can download here. And also, you should update your Keyman to the latest version if you haven’t done it yet.

Have a nice day!

1 Like

Hey, thank you so much for that. The problem is fixed! I do have a follow-up question for you, though.

I’m glad to know that the issue has resolved.

Please ask if you have questions! Thank you.

Thank you. :blush: I do have a follow up question. Before downloading the new Keyman keyboard, I only had two languages in my system: English (NZ) - with two keyboards attached to it (English and IPA) - and Chinese (simplified).

Now, having installed the latest version of Keyman, there suddenly appears English (US) with a US keyboard, English (US) with a UK keyboard, and another thing called Undetermined (Und-Latn - also with the keyman keyboard) - see screenshots. I’d rather not have all these extra input languages sitting there. But if I remove them, will Keyman IPA still work properly?

Related to this, when I go into Settings / Language & Region, I can see English (NZ), Chinese, and Undetermined as preferred languages, but English (US) - with either US or UK keyboard - does not appear on this list. So how can I remove them from the available keyboards list at the bottom of my screen?


I agree that it’s very inconvenient to have extra keyboards that you don’t need. I also experienced this before and what I did was restart my computer and the extra keyboards disappeared.

Here are what I have now:

In the setting:

Let me know how it goes!

Thanks for that. I’ve fixed the problem by installing English (US) as an input language, restarting my computer, then removing English (US) as an input language. This made both the keyboards associated with that language disappear. :blush:

1 Like

The conversation has resolved.