Non breaking spaces in Bloom

Is it possible to insert a non-breaking space in Bloom? Following French punctuation, we want to have non-breaking spaces before colons, question marks and other punctuation marks.

I suspect that Keyman is probably the best choice for achieving this by defining a sequence of characters that create the non-breaking space + punctuation character. I haven’t experimented with that but it shouldn’t be hard.
It is also possible to do this with Microsoft Keyboard Layout Creator, but it doesn’t support multiple keystrokes mapped to one or more characters, so it isn’t always suitable.

You can use any input method to type a non-breaking space such as you would use in any other program like Word or typing on the Web.

I have now been able to copy a non-breaking space from Word and paste it, so I have a workaround.

However, using spkl, the special characters program we use here, if I type a non-breaking space into Bloom, it just becomes a normal space.

Just to clarify my understanding of what you wrote: If you type the non-breaking space (using your input method) it ends up as a normal space, but if you paste in a non-breaking space, it works.

Yes, that’s right, typing a non-breaking space doesn’t work, but copying one from MS Word and pasting it in does work (copying and pasting from LibreOffice doesn’t seem to work).

Hi Clare,
I have two ideas.
One, you could send us information on where to get this spkl program, as I couldn’t find it.
Or we could add non breaking space to the “long press system” (the thing that pops up when you hold down a letter key in Bloom).

I think it’s probably not worth doing anything with spkl, it is only used here in Senegal. However, if the non breaking space can be added to long press system, that would be helpful, and would also be useful to people create books in French or other languages that use French punctuation rules.

@clare_orr OK we’ll do this soon and add it to the 4.8 beta.

Thank you! That would be useful.

This would be very helpful for us too. I just installed 4.8.34, testing Clare’s report I see that I can paste a no-break space into Bloom. But it seems “fragile”. That is, if I add a paragraph break before or after the no-break space and then delete the paragraph marker, the no-break changes into a normal space character, seemingly consistent with Clare’s report about typing a no-break in.

But I don’t see it as a long-press option. Which key would it be attached to? Or maybe it hasn’t quite made it into 4.8 yet?

fyi–LibreOffice is having some more general problems with copy/paste at present, Windows and Linux. Discussion over in PT support.

I could paste a phrase containing no-break sp from LO into Bloom, then delete the words surrounding the space, copy the space in Bloom, and repeatedly paste it into the story.

This is in the new 4.8.108 beta.
Hold down the space bar and select the no-break space.

1 Like

Thanks Andrew for doing this… it was much harder than we thought!.

Adding a non-breaking-space that Bloom’s embedded Firefox browser would not later remove proved quite difficult. For this reason, in the end, we went with a “narrow non-breaking space”, \x202F. At least for many French punctuation marks, this is what is recommended.

For now, as Andrew said, you would hold down the space bar and press “a”.


We could probably add something like Ctrl+space as an alternative, if this current method proves painful.

1 Like