No valid touch-optimized keyboards to install

#1

I keep trying to install the Bukawa keyboard (Bukawa.kmp) on Android. I had it working at one point, and then it stopped working, and I don’t know why.

My steps are this:

  1. Modify the Touch Layout
  2. Go to Build > Compile Keyboard (it compiles)
  3. Click Package for Distribution
  4. Click the Files “tab”
  5. Include Bukawa.kmx and bukawa.js
  6. Do I need to include Bukawa.keyman-touch-layout?
  7. Click the Compile “tab”
  8. Click Compile Package
  9. Copy the Bukawa.kmp file to Android
  10. Open it with ES File Explorer > Keyman
  11. It says, “Package Bukawa failed to install. No valid touch-optimized keyboards to install.”

Would somebody be able to look at my source files, project, etc and see if they can spot what I’m doing wrong?

My source files are here: https://drive.google.com/file/d/1X9B5EXBu0ARiXFjtPfb8wwWqpu94su8G/view?usp=sharing

Thanks,

James

0 Likes

#2

I had a quick look at the source files. The issue appears to be that you don’t have a language code association for the keyboard in the package source (.kps) file.

You do not need to include the .keyman-touch-layout file in the package; this is built into the keyboard at compile time.

One thing you should avoid is using mixed case in filenames, as this is troublesome cross-platform. I recommend renaming all the source files to use lower case only – i.e. no upper case ‘B’ (we enforce this for keyboards submitted to the Keyman keyboard repository).

0 Likes

#3

That worked. I had created this in Keyman 10, so missed that step. Keyman 11 does a MUCH better job of putting all the necessary files/settings together from the start. THANK YOU Keyman Team!

1 Like

#4

We are always so glad to hear when the things we work on are helpful to you! Thank you :slight_smile:

0 Likes