No progress on app build

I have a user of RAB who successfully built an app on her computer a couple of months ago (RAB 5.5), and when we got back to more app building, she wanted to do audio sync, so I had her install Aeneas. Now when she tries to build an app with RAB (whether or not it has audio), it shows the Build Android App dialog with the name of the app, and “Writing book: title…” and the progress bar goes to 100%, but then it doesn’t do anything else. You can close that dialog with the X in the upper right corner, but it never builds the app. We tried updating her RAB to 6.0.1, but it gives the same behavior. I copied her project to my computer and built the app without a problem, so it’s not a problem with the project. The other bit of information is that when we tell RAB to check the Aeneas installation, it basically just gives a command prompt - it doesn’t really check. I ran the Aeneas install again, and it did give the “OK” messages at the end, and I can “espeak hello”, but the check within RAB doesn’t seem to work.

Thanks for any suggestions…

What JDK is installed on the computer?

Can they build from the command line?

She has Amazon Coretto. I have not built from the command line before, but can give it a try. It looks like I would use this command from the Program Files (x86) directory:

rab -load "My App" -build

It also looks like she might have a slightly older Coretto, 8.212 instead of 8.222. I’ll try to get that updated as well. Might take a couple of days to get on the computer again…

From post on SAB:

So Corretto 8.212 had problems starting SAB. Though this problem seems different.

It is worth trying a newer Corretto.

Still no luck. We installed the latest Coretto, and it still didn’t build. (Actually, just to make sure, we also uninstalled Coretto and installed it again, but with the same result.

And when I try to build the app from the command line, I get the following:

C:\Program Files (x86)\SIL\Reading App Builder>rab -load “Le bouc” -build

Version 6.0.1
Build Release 37 (21-Aug 2019)

Load App Project:

Loading: D:\Fichiers\App Builder\Reading Apps\App Projects\Le bouc\Le bouc.appDef

Build App:

java.nio.file.NoSuchFileException: C:\Users\Antje Maass\AppData\Local\Temp\App Builder\books\Le bouc EL-000.enc -> C:\Users\ANTJEM~1\AppData\Local\Temp\App Builder\build\RAB.000\a\assets\DbDDgw4YQ6TPrNVhGCveKWY
at sun.nio.fs.WindowsException.translateToIOException(
at sun.nio.fs.WindowsException.rethrowAsIOException(
at sun.nio.fs.WindowsFileCopy.copy(

Any suggestions?

An additional piece of information… When the user tried to build an app with 5 books in it, the progress bar only went to 20% and stopped there. Again, no further progress, and the black command window never opens up to build the app.

This is a German computer. Any chance that there is a language issue on one of the commands being issued? Where are the files being written to, so that I can verify that they are being written to the right place?