No audio in output

I just tried to make an app from my FLEx lexicon to see how the newly-inserted audio would work. Unfortunately, none of the audio showed up in the app. Do you know how to fix this? I am using version 8.5 of DAB. In the audio tab of DAB, it says that each of my audio files (in .wav) are in Source 1, which it says are included in the app itself. However, I can’t find them. Thanks in advance for any help!

I have the same issue and would also love to hear how to fix this. What I found: When I record audio right in FLEx, the audio is imported into DAB and works just fine. When I import audio from an external file into FLEx, these files are not imported into DAB. Interestingly, both types of files are stored in the same folder in FLEx - the one seems to get imported into DAB, the other not…

Thanks for that information, Rhina. Yes, all of the audio files I have are ones that I imported from an external file into FLEx. Hopefully someone will be able to help us out . . .

I have reported this to the developers, but they aren’t able to spend much time on DAB, so please be patient. I can’t really think of a good workaround for this problem. You obviously could re-record the sounds directly in FLEx, but depending on the number of words, that could be a real pain. @Rhina You said that both types of files are stored in the same folder in FLEx. Can you tell us what the folder path is, and what “types” of files are used? If there are two different types of sound files, it may be that conversion to a different type of sound file may allow DAB to load those external files. Or (just brainstorming) you could record a dummy sound recording in FLEx, then replace it with your external file. Let’s see what Rhina says, and maybe we can come up with a better workaround.

@SusieL I can’t see where you said what you exported out of Flex, was it LIFT or XHTML. In either case I’d like to look at you output and your project. You can send me a personal message if you are willing to do that.

@jheath , thanks for reporting it to the developers! Yes, I can be patient. That’s why I wanted to start adding the audio slowly, in case it would take a while to get bugs out.

@Ian_McQuay , sorry, I exported out of Flex into LIFT. Sure, let me send you a personal message. A regular SIL e-mail address?

These are good questions, thank you. The files recorded right in FLEx are .wav, what I imported was mp3. However, I just tested what happens if you import .wav into FLEx and then create a dictionary from LIFT - same result, no audio in DAB. In FLEx, all these files are by default stored in

I then tested your approach to create a dummy recording in FLEx, copy the file name (usually with a long number and the word in the target language, e.g. 637629785991351660cansado.wav) and put it on the .wav file with the real audio. However, that doesn’t work either. I have no idea how this can be :thinking:

If you look at the LIFT file you will see that the WAV files have a language attribute of vig-Zxxx-x-audio but the .mp3 files have a language attribute of en. So that is a Flex issue to be fixed.

I did not find any working audio in the app you sent me. But you said it was working for you. So I am confused.

Hi Ian. Sorry that I wasn’t clear - none of the audio worked for me. Some of it was working for Rhina, I believe.

I don’t know enough about FLEx to be able to change the language attributes of the audio files - is that something that normally I should fix or that FLEx developers need to fix? I also don’t know where to see them, since I don’t know how you look at a LIFT file; I only know how to export and import them.

Also, I don’t see any .mp3 files in my data, so I’m confused as to where you found those (though I don’t doubt that you were able to find something that I wasn’t able to find!). Thanks for your continued help!

I did find one entry in the dictionary. The only one. It indicated there was audio to play that should have worked in the app. However when I went looking at the unzipped APK file, the assets folder had some PNG files in it and an illustrations folder that had your illustrations in it. But I did not see any audio files .wav or .mp3.

Did you add them to the DAB project that made the APK you sent me?

The audio files that I know, that worked in DAB occur with the head word or the pronunciation. In the one I saw as audio it looked like this:
The LIFT markup looked like this for the Pronunciation:
This is what I was expecting to see. A media element with an href attribute containing the file name.

Your other entries where I find .wav and .mp3 are like these:
I’m no expert on Flex, but I’d say if this one was like the previous one then it would work.

This one is not in the top part of the LIFT entry but in a sense:
As far as DAB is concerned it is just text. Does Flex play that back?

You could export an XHTML file from Flex and make an app with that. It may handle your audio better. Though I am not sure if they are set up correctly in Flex yet. XHTML export is a lot more work to get looking the way you want unless you want it to look like print.

Sorry for the delay in responding and thanks for the help.

That is interesting that you found that audio - I must have put it in there a few years ago as I was trying a different way of putting in audio. Here is how it looks in FLEx.

It plays in FLEx. The audio symbol showed up in my app, but it doesn’t play.

The other audio files, that I have been adding more recently, were put in differently, namely by holding down Shift as I clicked the circle on the audio line of the lexeme form. I was then able to import pre-recorded audio. They play in FLEx, but not in the app. However, they show up in DAB under the “audio” tab, whereas the audio for “godo” does not (sorry, I would include my screenshots, but since I’m a new user to this forum it only allows me to include one print screen in my response).

You asked, “Did you add them to the DAB project that made the APK you sent me?” When I exported the LIFT file, I told FLEx to export the audio as well. Then I saw the files in DAB as above. “Source 1” is specified as: “Package files with the app assets, inside the APK file.”

As far as the .mp3 that you saw as part of a sense that was just text, no, FLEx does not play it back. You are correct in saying that it is just text. It was a note to myself as to where I had gotten the audio file.

I tried exporting an XHTML file from FLEx and making an app from that, but perhaps because I don’t know how to go into the coding of things, when I imported it into DAB there were no entries in the dictionary.

ɪ tried putting one of the .wav files I was already using into the “media file” section of pronunciation, like the “godo” example above. I made an app with it, and since it was already used in the lexeme form, the audio file showed up on the list in DAB. However, when I made the app, though I could see the megaphone picture, it wouldn’t play, either.

Well, since a request has been put out to the developers to fix this issue, maybe we should just wait until a new release comes out that may fix it. Otherwise I may try to contact FLEx people at some point in time and see if they know what’s going on. Thanks for all your help, and hopefully these details will help someone eventually figure this out.

May I just check back: Has anybody actually contacted someone from the FLEx team?

I haven’t contacted anyone from the FLEx team.


After looking into this in my LIFT dictionary I am starting to doubt that this is a FLEX-issue. I have two very similar entries (only headword and translation), only for the one I used the record function of Flex (1), for the other the import function (2) using shift + record. Again, (2) does not work with .wav files either.

(1) Audio recorded in Flex; DAB recognizes

(2) Audio imported into Flex; DAB does not recognize

It seems that the structure of the LIFT file is identical which would make this a DAB-issue rather than a Flex-issue?

Let me add another observation to this topic, in hope it will be dealt with some time soon :slightly_smiling_face: When creating a new app, I imported a LIFT-file, obviously with all the audio attached. However, when DAB created the project folder, particularly the path

App Builder\Dictionary Apps\App Projects\MYNEWDICT\MYNEWDICT_data\audio

…it copied only the audio files that were recorded in Flex, not the audio files that were imported into Flex. It doesn’t help, however, to copy the audio files later into this folder.

This surprised me, as I would have thought that DAB just copies all the audio files from LIFT. Instead, during import it already picks and chooses…

Hello, Jason from the FLEx team here. Looking at this it seems that perhaps DAB does not support the audio writing system option in FLEx. @Ian_McQuay can you confirm that?

When you set up an audio writing system and record or attach files to the Lexeme Form it saves the file names in a different part of the Lift file. It seems that DAB supports the Pronunciation field but not audio writing systems.

If you have a lot of audio stored in the audio writing system it should be possible to do a bulk edit and move that data into pronunciations. If you have trouble with that contact fieldworks support and someone can help you figure it out.

Hi Jason. Thanks so much! I bulk copied all of the audio writing system from the Lexeme field to the regular vernacular writing system in the pronunciation field, and now the audio showed up in the app. That worked for me, so hopefully it will work for others with the same issue. Thanks!



That sounds interesting, but I couldn’t get it running because I failed to find the pronunciation field you are talking about. I went on an entry, clicked “Show Hidden Fields” > Pronunciation > Insert Pronunciation > Insert Sound or Movie and selected an mp3-file. After updating from source in DAB and creating the app, the audio symbol shows up, but no sound.

So what pronunciation field are you talking about?

@Ian_McQuay Any chance this can get fixed in the new year, since now the source of the problem has been identified?

@Rhina sorry I have ben swamped in dictionary projects I am working on for others.

I am not one of the developers, so some of the questions being asked, I can’t answer.

I have not had time to do any experimentation to figure out what does an does not work for LIFT in DAB.

Updating from source may not bring in new files. What show in your Audio > Audio Files section after the initial import? If any are missing I’d be adding them in. If they have a path in the LIFT URL for the audio file I’d remove the path part.