New Language Depot release

Dear WeSay and Send/Receive users,

On November 27th (next Monday) we will be releasing a new version of Language Depot (the site that WeSay uses for Send/Receive).

While we expect most things to just keep working, WeSay is fairly old software. It is likely that a configuration change will be necessary in order for Send/Receive to continue working (more information on that below). There are also a few other things to take note of.

Maintenance mode

Language Depot will be in maintenance mode between 00:00 and 04:00 UTC while we migrate to the new version. During this time Send/Receive will not work and both (aka and (aka will be unavailable.

Merging public and private

As part of this release we will be merging Public Language Depot ( and Private Language Depot (

Both public and private Send/Receive configurations will continue to work.

What to try if Send/Receive stops working

If you can’t Send/Receive here is what you should try:

  1. Open the Send/Receive Settings for your project
  2. For Server select Custom Location…
  3. For URL use the following: https://[your LD-login]:[your LD-password][your project-code]:

Why would this fix it?

WeSay uses HTTP by default, which the new version of Language Depot no longer supports for security reasons.

If something stops working

Please let us know and we’ll see if we can fix it.

Swapping out a 13 year old system is no easy task, so please be gracious if we run into a few unexpected hurdles.

Why are we doing this?

The new version of Language Depot is the first step of modernizing the Send/Receive and language data tool set. Freeing ourselves from the current/old site will allow us to rethink how language data is stored and synchronized. It will also enable us to expand the feature set of Language Depot.

Warm regards,
The Language Depot development team

Hi, my send/receive did indeed stop working, and following these instructions hasn’t fixed it. Before, I was getting the same error message over and over until the program froze. Now, I changed the URL under custom location, and I’m getting this error:

Warning: There is an authorization problem accessing this project. Check the project ID as well as your username and password. Alternatively, you may not be authorized to access this project.
Exception: Failed to get remote revisions for mmy-dictionary

Error: Failed to get remote revisions for mmy-dictionary

I have double checked my user name and password. What else can I try?

Thanks for the report, Sarah. WeSay hasn’t published a new version in almost 5 years, but I still have to ask: are you using the latest WeSay version?

WeSay for Windows MSI 66.55 MB 6 Feb 2019

Yes, that’s the version I have. I’ve talked to my team leader and she thinks the problem may be that I’m not the project admin, so I’m waiting to find out if she can fix it.

Hey Sarah, thanks for letting us know you’re having trouble!

I have 2 ideas:

  1. I think this is what’s wrong ==> Could it be that your URL starts with http instead of https - the “s” is crucial.
  2. Otherwise, if you have special characters in your login or password and you type those character manually into the URL that could also cause trouble. In that case make sure you enter your login and password into the provided Login and Password fields before you switch to Server: Custom Location….

Let me know if neither of those ideas fix the problem!

Hi Sarah,

I think we finally found the “oops” on our side.

The new version of Language Depot has made logins case-sensitive.

We should be able to fix that on our end today for 99.9% of our users.

The immediate fix on your end would be to either:
(1) use your e-mail address instead of your login, which is case-insensitive or
(2) fix the case of your login (we don’t currently show logins in the new site, so that might be tricky without the help of an admin)