MacBook Catalina Classical Greek iota subscriptum Word

Using Keyman Classical Greek in Word on MacBook Catalina OS, I experienced the following problem. The possibility to type a iota subscriptum suddenly disappears. It seems having to do with inserting a table as I can’t type the iota subscriptum in the table.

I tried to copy a part of the document in which I can type a iota subscriptum, to the disabled part without succes. Also replacing the table above the part where I could type the iota subscriptum, didn’t make any difference.

Who could help me solving this problem/bug(?) ?

Welcome to the community!

I’ll try and help in investigating this issue. We have a number of classical Greek keyboard layouts available; can you confirm which one you are using (you can get the full name from Keyman Configuration)?

Which keystroke are you using to type iota subscriptum? If you select a macOS native keyboard and type the same keystroke within a table, what happens?

Dear Marc,

Thanks for your quick response. I will try to answer your questions.

1 I am using Keyman Version 12.0.50 and Greek keyboard layout Classical Greek.

2 To type iota subscriptum I type key a en key | (shift backslash), doing this here I get ᾳ (the right one). Without Keyman this combination results in a|.

I show you below the strange situation in Word.

As far as I know this problem has to do with Word and inserting table.

I hope to hear from you soon. With kind regards,

I am going to have to run a test on my MacBook with Word in order to try and reproduce this strange issue; I’m a little buried on a number of things but hope to get to it early next week. I’ve added an issue into the project to investigate.

Okay, I believe we have a fix for this issue. I have tested the fix successfully on my MacBook running macOS Catalina 10.15.3 and Word 16.34 (20020900).

The fix has not yet made it into a public build, but we have a test build available at https://github.com/keymanapp/keyman/files/4189027/keyman-13.0.0.dmg.zip if you want to try that.

The public build should be available as a pre-release beta version at https://keyman.com/beta in the next few days and as a stable 13.0 release at https://keyman.com/mac in about 2 weeks.