Left alt key still gets stuck when it's rebound to a different key

You’ve all probably seen this post, in which someone’s alt key got stuck when they pressed it while keyman was active.

This is still the case if Powertools is used to rebind Left Alt to a different key.

Edit: Just tried rebinding my windows key (previously bound to left Alt) to right Alt instead, and it still got the alt key stuck when I pressed it.

Hi @MrHiTech, welcome to the community!

Which version of Keyman are you running? We believe this issue to be fixed in 16.0 stable releases.

I am running either Keyman 16.0.142 (just un- and re-installed) and it is still an issue.

@ross can you look into this with @MrHiTech?

@MrHiTech, would you be able to send us a diagnostic report following the steps at https://help.keyman.com/kb/40 and reference this discussion in it? That’ll help Ross start to dig in to why this is happening for you.

Note: if this issue is happening whether or not PowerToys mapping has been applied, it would be good to disable the PowerToys mapping for the purposes of diagnostics, as it simplifies the picture for us. Thanks!

Seems to only apply when I press my windows key, which has been rebound to alt. I tried rebinding it to right alt, and it still raised the issue.

When I rebind any other key to alt, (the left ctrl key for example is the one I tried), it does the expected behavior. Same when I don’t bind it at all.

I’d be glad to send a diagnostic but I’d like to confirm that my keylog info won’t be sent (I think I read somewhere that you guys log those but I’d prefer if that wasn’t sent)

Following the KnowledgeBase 40 to send a diagnostic will not include the they keylogging. It will give more information about the input methods and languages installed for your system and other keyman-relevant registry values.

KnowledgeBase 76 found here will log your key press for the time you turn it on till when you turn it off again. The idea would be you turn it on type the test sequence and turn it off again. I will see if I can reproduce your problem first before asking you to do that logging describe in KB76.

Got an error in my diagnostic sending thing


“You must select a valid user”?

Please advise

Wouldn’t let me put the error in the first post so putting it in a different post

If you are unable to send it directly, you can save the diagnostic report from the File menu and then attach it to a private message on this forum.

1 Like

This conversation has been resolved.