Kmp does not install directly into Keyman for Windows but works everywhere else

Hi all, I do not have much experience with Keyman so I hope I’m not doing something wrong.

When I try to install a kmp that I created via Keyman Developer to Keyman for Windows, it gives me this error.

The kmp installs fine to Android.

When I install they keyboard to Keyman via Keyman Developer using the Build tab, it works great.

When I create a Windows installer via Keyman Developer for this kmp, the combination of Keyman with the kmp installs and works great.

So everything taht I have tried with this kmp works except installing it just as a kmp from ‘Install Keyboard…’ in Keyman Configuration screen.

Does this strange combination ring any bells?

Hi @Corey_Garrett.

Just linking this to the crash report (you can use the “Copy to Clipboard” button in the dialog that you got a screenshot from to help us with this):

Looking at the root cause report, I can tell you that it has not been widely reported, so it’s not a common issue. Can you share the .kmp file with us (via DM on the forum is fine)?

One question: where is the .kmp file stored? Is it somewhere that might not be accessible to the Administrator account which needs to access it during the install process?

@Marc, you got it - the location seemed to be causing the problem. Copying it to the C:\Users…\Documents folder and installing it from there worked just as expected.

More info: I am running Keyman for Windows under Parallels on an M1 Mac. It was in a folder on the hard drive that Windows has write permission to but is finally ‘really’ in macOS, mapped as a network drive with a drive letter.

Thanks for that push in the right direction!

1 Like

Great! Thanks for the update @Corey_Garrett. I’ve logged this as an issue for resolution at #6412.