Khmer keyboard misbehaving

Am not able to type right alt + colon to get the Khmer ‘colon’ in libreoffice on wasta-linux. Previously I had both Khmer Angkor keyman AND Other - Khmer (from kmfl PPA) installed because Khmer Angkor was doing strange things with vowels towards the right side of the page - so I switched to the kmfl keyboard. But having both installed causes inability to switch out of Other-Khmer using keyboard shortcut. So I removed the kmfl keyboard in case having them both was causing the oddities. So far no problems with vowels towards the right of the page but I cannot type the Khmer colon. Tried restarting my machine, opened new libreoffice doc, and I typed it fine. But it has since stopped working again. Is there a log I could take to send you? Thanks.

Ian

Edit … it has started working again ៖

Thank you for reporting the issue. It is good that it starts to work again, but…

Could you please take a screenshot and describe this a bit more?

It would be helpful to dig a little deeper on this. If the issue is with Khmer Angkor, I can help fixing it pretty quickly as long as I can reproduce the error and figure out how to resolve it. :slight_smile:

Makara

Hey Makara. I’ll let you know if I can reproduce it. I’ll try with and without the kmfl keyboard installed/added.

Ian

Hi Makara,

this just happened in Libreoffice Writer, see screenshot below. Running Wasta 18.04 without any other KHmer keyboard installed except Angkor.

That’s very weird. I’ve never seen it like this before, and this case it’s with Bantoc, a diacritical mark. It’s not only with vowels. I will look into it further.

What is your LibreOffice version?

I’m wondering if this is a display issue in LibreOffice rather than a keyboard issue. After typing Bantoc and having it not appear, can you try adding a line break (i.e. carriage return) in the middle of the same line, just to see if it suddenly appears when the line of text redraws below?

In response to what Marc just said about it being a display issue in libreoffice, I just tried to reproduce the error but couldn’t. I typed a whole line of ក់ in the same document as the first error from the screenshot above, and it typed fine. I scrolled up to the same line I had the error before and I could type fine also. I got round the error by typing my word on the next line down then backspace-delete to the line above to get it where I wanted. If I get any other curious things happening, is there a log I can send?

Ian

I’m not aware of a useful log in LibreOffice. I guess if it happens again, try why I suggested. You could also try selecting the line (start well before and finish well after the missing diacritic to make sure you capture it) and copy and paste it into a text editor to see if it looks the same there.

OK. If it is something to do with libre office, would Martin Hoskens be a good person to help?

Perhaps? I’m not sure if he is doing any work on LibreOffice these days.

OK, so here is a test case. I was typing in a libre writer doc, reached near the end of the line, tried to type a word with ស្រៈអុ but it did not appear on the page. So I first tried again, then pressed return, typed it once more followed by some other characters. I then copy pasted the text into a text editor, but as you can see from screenshot, all that is visible is the word I typed at the end of the 1st line (កម្ពុ) minus the ុ and on the bottom line you can see the ុ which I retyped followed by ជា. So in actual fact I typed the ុ about 3 times in total.

Update: same libre writer doc as above, I was at the end of a line and was next going to write the word ដែរ. Before I typed, the cursor was at the end of the line. When I typed the ដ you can see it typed correctly but at the start of the line below. When I typed the following vowel, the ដ​ disappeared. Copy pasting into text document didn’t show a ដ at all, even though I had typed it. On the first screenshot below I am talking about the line directly under the number 2. I was going to write: ឃើញ​ដើម​ថ្នោត​ផង​ដែរ (ignore my spelling mistake on ឃើញ).

This is weird. I am not really sure what is going on; it doesn’t smell specifically like a Keyman bug although it is of course possible. I don’t have any immediate ideas on how to proceed with debugging it given the issue does not consistently occur…

I’m not 100% sure it works in every fail case, but switching out of Khmer Angkor then back into it sometimes solves the problems. This morning I’ve had 2 little bugs:

  1. Near the end of a line, but not right at the end with text already typed both to the left and right of the cursor, I typed វា (va) but the vowel would not appear. I clicked with the mouse on the line below and the same thing happened.

  2. Just tried to type Khmer colon (RAlt :wink: ៖, nothing happened.

Both cases were solved by switching out and in of the keyboard. Maybe it is connected to what Lorna mentioned about keyboards using RAlt to type characters on Windows machines.

Ian