Keyman Slows Down Malayalam Typing in MS Word

Hi there,

I am using Keyman for Malayalam (Mozhi Scheme). When I type in MS Word, it takes 2-3 seconds for the letters to appear on the screen, while with WordPad or on a browser, it is completely fine.

I am using MS Word - Office 365 version.
I am also using the Grammarly plug-in. Could it be the problem?

My laptop is brand new. The config is fine. AMD RYZEN 5 processor with 8 GB RAM and 250 GB SSD.

Here are two screen grabs on this delay issue.

In both Default font and in other Unicode fonts, the issue persists.
Could you help me to figure this out?

Thanks a lot for your help.

Hi @akhil, have you tried disabling Grammarly temporarily to see if that resolves the issue? Can you try that first before we dig deeper?

1 Like

Hello, @Marc Thanks a lot for your prompt response.
Yes. I tried disabling the Grammarly plug-in. Still, the issue persists.
Here’s the current status (my screengrab).

There are 3-4 seconds of delay when we type very fast.
If we type slowly, each letter may take 1-2 seconds.

Thanks for the follow-up. I’m not entirely sure what is causing this. Some more questions:

  • Does this issue occur with short documents as well as long documents? Is the delay affected by the length of the document?
  • I saw that the title bar of Word showed ‘Saving’ for extended periods of time. Can you try turning off the auto-save option at the left of the title bar?
  • Can you try copying the text of your document into a new document in Word and see if that makes a difference?
  • Do you have a sample document you can send to us in a private message for me to experiment with?
1 Like

Hello @Marc

Thank you for helping me out.

Yes. Here are the results of the debugging steps that you suggested.

  • Does this issue occur with short documents as well as long documents? Is the delay affected by the length of the document?

Tried with a shorter document. The result was the same.

  • I saw that the title bar of Word showed ‘Saving’ for extended periods of time. Can you try turning off the auto-save option at the left of the title bar?

I turned off the auto-save option. Didn’t see any difference. Here’s the outcome.

  • Can you try copying the text of your document into a new document in Word and see if that makes a difference?

Tried copying to a new document. The delay is still there. Here’s the outcome.

  • Do you have a sample document you can send to us in a private message for me to experiment with?

Will share it with you.

Hi, I’ve tried testing with your documents and I can see the issue here. Furthermore, I tested with a standard Windows keyboard and saw the same problem. I could even add English text to the document and see the issue. The issue appears to be with long paragraphs of Malayalam text, perhaps to do with line wrapping in Word. We have sometimes observed similar issues with Khmer text.

Given I can reproduce this with by typing random Malayalam characters into a document using a Windows keyboard, I think the best way forward may be to raise this as an issue in Word, with Microsoft. I’ve flagged this with a contact at Microsoft; let’s see if they have any suggestions.

1 Like

@Marc Thanks a lot for clarifying it. Thanks a lot for helping.
Let me try to report this issue to Microsoft.