Keyman not working in google drive

I have a keyman keyboard that includes special characters I need for the language I work in.

I have had no problem using the keyboard with google drive until recently. it continues to work in word, but not in a google doc or in anything on a google drive.

I have updated to the latest version of keyman

I have run control_chrome_tsf.exe as suggested by Phil Leckrone

it still does not work.

He suggested I contact you for help.

Welcome to the community @wancaman,

Please provide the information we need to reproduce the behaviour:

  1. Is the issue happening on Windows? If so, please provide us the Windows specification.
  2. Could you tell us the name of the Keyman keyboard that doesn’t work on Google docs?
  3. Does the keyboard not output anything when typing on the Google services?

When running the command above, did anything show up like the document says?

We look forward to your response.
Thank you.

thanks for your response.

  1. i am running windows 11.
  2. keyman lists the keyboard as qvw.
  3. there has been output when trying to use the keyboard with google services. and, surprisingly, i just tried using the same keyboard to respond to this note (gmail) and there is no output. this is the first time i’ve noticed this. it DOES work in a Word doc.

when i ran the control_chrome… program, i was NOT prompted to elevate this to an administrator, but i DID get the prompt for yes or no for default integration. i chose ‘no’.

standing by

Thank you for the information @wancaman.

Currently, we are unable to reproduce the behavior of the issue. Would you be able to send us the keyboard package?
What is the version of Chrome that produced this behavior?
Is this the Keyman version you have?

In addition to the required information listed above, we suggest sending a diagnostic report as well.

thanks to Babel, i have a job.

Rick Floyd
Senior Translation Consultant
SIL International
rick_floyd@sil.org

wanca_uni.kmx (2.92 KB)

Hello again @wancaman,

We received the diagnostic report and we are unable to reproduce the behavior of the issue. Did you install or update any software around the time that it stopped working?

We test the keyboard on Windows 10 and @Nguonnyny_Tan test it on Windows 11 but both machines output normally on Google Docs and Gmail.
It’s difficult to track intermittent issues like this. Along with not being able to reproduce it on our machines.

As of now, has any of the Google services or other applications on your Windows 11 not output the keys?

P.S I am using wanca_uni.kmx keyboard to response to this on the community site.

I suspect it’s something lurking somewhere in my computer. I migrated to a new computer this morning and the problem has disappeared. Thanks for your help.

1 Like

Thank you for going through this whole process together.
We’re glad that it resolves the problem for you.

Please feel free to create a topic if there are any questions.

This topic was automatically closed after 14 days. New replies are no longer allowed.