Keyman keyboard just... disappeared? (iPhone)

I’ve had the app for over a month and today when I opened up the Keyman tab on my keyboard, it just showed a blank pop up, without even an option to change the specific keyboard. It works fine within the Keyman app, but it doesn’t work for any other apps. It was working just fine a few hours ago. Has anyone else had this issue/does anyone know any fixes?

Welcome to the community, @lovelee. Thank you for reaching out to us.

If you haven’t yet set the keyboard as a system keyboard, do so following the instructions here: Installing the Keyman System Keyboard - Keyman for iPhone and iPad Help and let us know if it makes any different.

If you have, yet it doesn’t work for you, please give us more details.

  1. What is your iOS version?
  2. What version of Keyman for iOS are you using? (We recommend the latest stable for better performance.)
  3. Does any keyboard show up at all when you touch in a text box to type, i.e. iPhone default English keyboard?

It works fine within the Keyman app, but it doesn’t work for any other apps.

I take it that this means it’s consistently blank.

I’ve had the app for over a month and today when I opened up the Keyman tab on my keyboard

This is quite interesting. So things suddenly broke today after working fine for a long time.

Has your phone recently updated?

Also, I assume you’re using the standard version of Keyman from the App Store, right? (Rather than one of our beta versions via TestFlight.) What version do you see at the top of the in-app “Info” page?

image

I’m asking for the part saying “Version: 15.0.91-alpha-local” in this screenshot.

without even an option to change the specific keyboard.

While we look into the issue, you should be able to force a keyboard swap by going into iOS settings and temporarily removing Keyman as an option. The second option in the Keyman app’s “Get Started” menu can be used as a shortcut to the right iOS settings page.

You may also want to try uninstalling, then reinstalling the app. (The classic “turn it off, then on again” approach.) Do let us know whether or not this works if you try it; that may give us some useful information to fix the underlying issue.