Keyman keyboard disactivated when websites ask for my password

For example the SIL IIDP site when I want to log on to Gateway or Workday.

The site comes up, I confirm that my Keyman keyboard is active by checking either the lower right on the taskbar, or Windows + space. The Keyman keyboard works when I type in my user name, but reverts to the standard keyboard when I type in the password box.

(In the SIL IIDP, I can doublecheck what I have typed in the password box by turning on the Developer tools in the browser and entering this string in the console:
document.getElementById(“password”).value. The SIL IIDP developers say they don’t have any special processing going on with the password field. I can use an alternate Windows keyboard like US International in the password box.

I’ve seen one other website where this happens.

Okay, I had never observed this (as I have avoided using non-basic-Latin strings in my passwords).

It turns out that this relates to the browser, and not the website. I am assuming you are using either Chrome or Edge Chromium – I have reproduced this behaviour in those browsers. Firefox does not implement this behaviour.

By design, Microsoft suggest:

All passwords fields should have text services disabled to maintain password secrecy

Chrome implements this behaviour and explicitly disables text services when a password field is active.

This means that Keyman and also Chinese, Japanese, Korean and other IMEs will not be able to function within password fields with these browsers.

Thank you for reporting this – it’s good to be aware of it!

Workarounds

If you get stuck unable to type your existing password in, there are some workarounds you can use:

  1. Some sites have a “Show Password” mode, if you enable that then you should be able to type it using your Keyman keyboard.
  2. Type your password into Notepad and paste it into the password box.
  3. Reset your password and create a new one that uses only the basic characters available on English US keyboard.
  4. Use a password manager to store your passwords so you don’t have to type them (recommended!)

Thanks for that info. I can indeed use my keyboard to log on with Firefox.