Keyman installer fails when elevating to a different Administrator account

Congratulations on the new free Keyman.

I did have an issue installing it though. I don’t use an administrative account on my computer, and I could not install Keyman. The installer asked me to authenticate with an admin user name and password, I did that, and then it gave an error that “setup.inf” could not be found. Running the installer as administrator also failed with the same error.
I did manage to get it installed by logging into the administrative account, then running the installer.

Thanks Steve. Can you give a bit more detail on the steps you took, and whether the Administrator account had the appropriate permissions in the folder in which you placed the installer? This scenario is one we have tested in the past successfully. Also, the version of Keyman you were installing would be helpful.

It is 9.0.528 that I downloaded half an hour ago.

The administrative account does have full permissions to my “Downloads” folder which is where the downloaded file was saved. I tried running the installer after the download, then I tried right clicking on the installer and saying “Run as administrator” which both failed.

I did have an earlier version of Keyman 9 desktop installed, which I did not uninstall first.

Okay, thanks for the additional data. We’ll try and reproduce the issue here and see what we come up with (this may not happen immediately). See for a trackable issue.

I’m not seeing this behaviour when I test here; on a test computer I created an administrator account and a standard user account, then ran the installer from the standard user account. Windows prompted for elevation along with username and password, and then Keyman installed successfully. So there’s something different in your configuration and mine. Are both accounts on the same domain on your machine?

Additionally: which version of Windows?

This is Windows 10 Pro, version 1511. My standard user account is on the
campus domain and my admin account is on the local computer – it was set
up this way by Jaars network services. I just tried again, uninstalling
Keyman 10 and installing the latest (10.0.946). I got this error still
relating to setup.inf:

But I did try elevating to a second local computer admin account I’ve
created, and with that one the install succeeded. I suspect the difference
might be the admin account that the network team set up has no permanent
profile, when I login to it Windws says the profile is only temporary and
anything I save there will vanish when I log off.

Steve White
International Language Technology Consultant

That’s helpful information, thanks: I’ve added it to the issue. Given you have a workaround, can we leave this as low priority for now?