Keyman GFF Amharic keyboard and OSX Sierra (compatibility issues with Word, etc.)

I use Keyman for Mac on OSX Sierra.
I downloaded the following keyboard:
GFF Amharic Keyboard

Firstly the on-screen keyboard appears but it doesn’t work. I can push the buttons, but nothing appears in Word.

Also the instruction says that when I type selam it should produce the amharic for selam.
But it doesn’t.
It produces this:ስ ሰልሰላም
It acts very strange, even sometimes deletes previous characters when typing new ones.

Also I have a belgian AZERTY keyboard, is it possible to combine this with keyman?

Because of the way the Ethiopic script works, none of the GFF on-screen keyboards actually work as true on-screen keyboards (OSK). They are there to give you a guide on what to type. I know that seems senseless, but because Ethiopic has so many characters you need to type between 1-5 keystrokes to get the character you need. I don’t know if the Belgian AZERTY keyboard is your problem or not. You should be typing “selam” (wherever the keys happen to be on your keyboard, don’t follow the OSK). Typing “ss” produces a different character, so yes, when you type “s” it becomes one character and then when you type another “s” it replaces the first character with the second character. The last 3 letters in your example are correct so I think you were trying different things before you got it right.

Still it didn’t solve the problem.


I just only typed “selam”
and it shows a lot of other different things.

another test, in the webadress bar of opera it works perfect. Typing selam results there in:

typing here results in


and typing in editor from mac also gives the right result. In word and other editors it doesn’t work as it should.

Thanks Kevin for the feedback. Keyman for macOS is currently in beta, and has some known issues that we are working on resolving. It sounds like there is a compatibility problem with Opera and Word. We were aware of some compatibility issues with Word, so will look at that and Opera along with the rest of the development work we are doing on it.

Ok, If you need help bug testing I am available.
I use Word for Mac 2011 btw.

Also I have an azerty keyboard but for using Keyman, I have to use it as a qwerty. So it doesn’t translate to my azerty keyboard.

Thank you! We’ll be pushing out updates into the version 10.0 alpha channel at regularly as we start to get more of a handle on the issue. We’d love your feedback!

I don’t understand. I am using 1.1.14 now. But on the link you gave me
it is version 1.1.9
Is this right?

So currently you are using the latest version 1.1.14, which is a ‘beta’ version.

We are starting work now on a new major version to bring the macOS version into the same stream as the other platforms we support. This will be version 10.0. We have not yet released an version 10.0 updates. When we do release an update, you’ll see a 10.0.x folder appear in the alpha downloads site.

You can learn more at

Ishi, (Amharic for ok).

Can you post here when there is an Alpha available. So I can help bug testing.

We’re looking at automating version announcements either here or elsewhere on the keyman sites but don’t have anything in place yet.

You could use a tool such as to watch (or to watch for new versions in the meantime.

The alpha (10.0.11) is now available.

The keyboard SIL Ethiopic can activate and works on Safari, Finder, Adobe Acrobat but does NOT work on Word, Airmail, Keynote.

I am using Mac High Sierra 10.13.2

Any ideas? I tried to download 10.0.11

I downloaded latest Keyman keyboard, then after downloading Amharic font I get the error message:

There is no application set to open the document “gff-amh-powerpack-7.kmp

Thank you for your feedback. We are continuing to work on improving compatibility across macOS X apps – there is a lack of consistency in application implementations which does make this challenging, but we are getting closer. If you have more details on what is not working in each app, that would be helpful feedback.

Regarding the error ‘there is no application set to open the document’: follow the steps at to successfully install the keyboard.

Hello, thanks for you response.

I had removed the Keyman input source when i was getting the error i
posted, one you wrote back about. Now when i try to add it again i get
error "The item “background” can’t be replaced because it’s invisible.”

Any ideas please?

Looks like The item "_" can’t be replaced because it’s invisible. is a common issue on the Mac. Not exactly sure what “background” is in this case, but it’s presumably either a file or a folder, perhaps something in the Input Methods folder that got left behind when you previously tried to remove Keyman. This page might help you be able to see what’s hidden so you can delete it: Let me know if that helps.

I removed everything and tried to start from scratch. Now I am able to load Keyman (Sys. Pref> Keyboard> Input Source> + Multiple Language…), but it does not show up the keyboard menu (at the top of the screen) so cannot use it!