Keyman for Windows is non responsive when used in Parallels

I just fielded a request for help from a user regarding Keyman. She has a Mac, and is also using Windows through Parallels.
Keyman works fine on her Mac. It does not work in the Windows VM. Keyman will start, she can select a keyboard, but Windows will switch back to the default keyboard when she attempts to type in Notepad or Wordpad. We were able to get Windows to keep the IPA keyboard as the proper keyboard, but it would not type IPA.
As a test we installed the Thai Unicode Keyman keyboard and tried to see if she could type Thai in Windows using that keyman keyboard. It did not work. When we activated the Thai onscreen keyboard, the keyboard would show the proper Thai character, but it would actually type the latin character on the English (US) keyboard. a instead of ฟ Any assistance would be appreciated.

To clarify the setup:

The user has Keyman for macOS installed on the host Mac, and it works fine.

In the Windows 11 VM, the user also has Keyman for Windows (16.0.144) installed. And that’s the one that doesn’t seem to be working (tried MS Word and Notepad).

“Not working” has symptoms like:

  • a lot of times, Windows reverts to ENG keyboard
  • even when a Keyman keyboard is selected, the text is regular English (no IPA modifers or Thai output)

If I recall correctly, Parallels has some funky support for trying to interact with the selected macOS keyboard. Again, from what I recall, there is a way to turn it off. That is the most likely thing that I can think of. (Haven’t had a chance to research, just wanted to keep ball rolling on this)

The following two articles may be helpful:

There are also a number of issues in the Keyman issue tracker which reference Parallels, and this one in particular may be relevant: