Keyman doesn't work with

I was just trying to create a site on, and when I typed I was getting all sorts of garbage. When I turned off my Keyman keyboard, it started working fine again. Is anyone else seeing that problem? Is this a known problem?


@jheath this is not something we’ve seen before. Can you give some more detail on the issue – which browser, operating system, version of Keyman, keyboard, etc? If possible, a screencap of the issue would help as well.

I’m using Firefox 124.0.1, Windows 11 23H2, Keyman 16.0.147, I’m using a new test version of Tchad QWERTY that we are developing, but the same thing happens if I use the Tchad keyboard currently in the repo.

I did a screen capture, which should be available with this link:

But it didn’t capture the mouse, so let me give you a guided tour…

  • My Tchad QWERTY keyboard is already activated
  • I start on this community page, then open the link above in a new tab
  • From that tab I click on Blank site to start a new site
  • I select the title text and change it to Arial (something that can handle Unicode better)
  • I type “Test a[e] /b/n/e”
  • With this keyboard, that should result in the text “Test áè ɓŋə” (but it doesn’t)
  • Then I type backspace 6 times to get rid of those last 3 letters (should have only been 3 backspaces)
  • Then I type “test” and those last 3 letters magically reappear

If you actually do this test, and try to click the insertion point to insert or delete characters you will see very wacky results. There is no way to “clean up” the text that was produced. I found the best way to enter the text was to type it in some other program, then copy and paste it into the Google site.

Hope that helps track the problem down.

Thanks for the detailed response and repro steps. I have opened an issue to track this because it looks like a compatibility issue specifically with Google Sites, which may take some digging into. We may reach out to Google as well.

At this point I don’t have a better workaround than what you’ve already done – copy and paste =.

I was getting an inconsistent repo on my Win 11, Chrome, Keyman sil_ipa keyboard
On when I tried to start a new title, sometimes the sil_ipa keyboard was active but typing “n>” remained “n>”. I toggled off to English and back to sil_ipa and then “n>” became “ŋ”.

What happens if you toggle Keyman like that?

I tried to type the “a” with acute accent (typed as a[ with my keyboard) 5 times, with keyboard on, then toggled off, then toggled on, then toggled off, then toggled on. This is what I got:


But what bothers me most is when (with the keyboard on) you press backspace a few times, and then start typing something else - the stuff that you deleted seems to come back again!

Thanks all for looking into this, and the work-around works for me for now…