Keyman developer 16.0 UI question

Hi all, I had not used keyman developer in a very long time (since v9.0!) and recently upgraded to version 16.0.
I have a small niggle about the interface…
In older versions of Keyman Dev. you could double click on a unicode value in the main panel (say U+00C3 for example) and ti would automatically show you the relevant entry in the character map window.
In this version when i double click on a unicode value it either only selects the last 4 charactere (00C3 in the case of U+00C3) or selects all the occurences of “U” in the main panel (if I happened to double click when hovering over the “U”).

The only way I can get the character showing up in the character map and character identifier panels is by manually selecting (click and drag) the whole sequence - which can get very tedious.

Is it a bug, a feature, and is there a workaraound?

Thanks in advance for any hints !!

Den

Welcome back to the community @Den_Hol,

I’m sorry to hear about this inconvenience. You can click on the Unicode value text or the keycap and the character map will automatically show the character you are selecting. It also shows on the Character Identifier panel. This works the same for Layout tab and Touch Layout tab.

Please ask if you have more questions.

Have a nice day!

Hi there,

Thanks for your help, unfortunately this is not the behavior I am experiencing.

Please see the attached screenshots. When I double click on a Unicode value text I either:

  • Only select the “numerical” value which doesn’t trigger the character identifier nor the character map (snip1)
  • Select all the instance of ”u” in the text (snip2)

Kind Regards,

Den

~WRD0001.jpg

Hi Den,
I’m not quite sure I understand what you are wanting, but here goes.

If you don’t double-click, but just put your cursor somewhere in the codepoint, you should get the character showing up in both the identifier and map windows:

You may also want to turn on the ability to insert the codepoint rather than the character. You can do that by right-clicking on a character in the map window and select Insert Mode and then choose Code instead of Character. That is my own preference, but the default seems to be Character.

image

Otherwise, I do think the behavior you get when double-clicking is a bug since you are getting a seemingly random character. You could submit a bug or request here: Issues · keymanapp/keyman · GitHub

1 Like

The double-click is selecting the letter ‘U’ because a double-click selects the “word” under the cursor. So the editor is behaving as expected. As @lorna says, if you just place the cursor anywhere within the U+xxxx text, either with a single click, or by using arrow keys, you should see the character map tracking the character.

Do check that you haven’t turned off the character map tracking option in Tools/Options:

image

1 Like

Hi Marc,

I have checked and the character map tracking is on.

The behavior is the same as described previously whether I place the cursor
manually in the U+xxxx text or single click anywhere in it.

I will try to reinstall the product to see if this solves the issue.

Dem

~WRD0001.jpg

@Den_Hol, did reinstalling make a difference?

If not, we could do a remote support session to try and track down the cause of the problem; let me know if that is of interest to you.

Hi Marc,

Thanks for getting back to me.
I’ve tried twice to uninstall and clean re-install of Keyman developer.
Unfortunately no change.
More than happy to do a remote session if that works for you !
(Noting I am in the UK and if I recall you are in Australia?)

Cheers,

Den

~WRD0001.jpg

(Organising remote support via private message)