Keyboard lag in LibreOffice Writer 7.2.x with InKey

I have been using InKey 2 for years without any major problems, also with LibreOffice up to version 7.1.6, currently in Windows 10 Pro 21H1 64-bit.
Unfortunately now in LibreOffice Writer 7.2.1 and 7.2.2 there is very annoying keyboard lag when InKey 2 is on (which I have running all the time). So much that I needed to revert to LibreOffice 7.1.6.
I would gladly switch to Keyman, but unfortunately Keyman doesn’t seem to be compatible with AutoHotkey (1.1.33.09), which is also running on my system all the time. When Keyman runs, my AutoHotkey shortcuts in the form of ::aa::bbbb, which I constantly use, don’t work any more. (At least that was the case with the latest Keyman version I tried some months ago.)

Is there anyone who has experienced such problems? Might there be a setting in LibreOffice, InKey or Windows that could alleviate the problem? Since InKey has this problem, I wonder if Keyman has it too? And is anyone successfully using Keyman together with AutoHotkey shortcuts as I described? Might there be someone with more technical background who could give input to the LibreOffice developers?
It would be a great help if this could solved as otherwise I will be stuck with LibreOffice 7.1.x.
Thanks,
Roland