Keyboard doesn't work in Word documents

Greetings. I use a Windows 11 computer. I have other Keyman keyboards that work fine. I just installed the Musnad keyboard for the Old South Arabian language. In Microsoft Word texts, I just get boxes. What is strange is that the OSA letters appear fine in the search feature in Word, and also in Notepad,𐩱𐩨𐩱𐩪𐩧𐩴 and, as you can see, here too. But they don’t appear where I actually need them, in Word documents. And, no, copy-and-paste just turns them into boxes. Help!

I got boxes too. When I selected the text and changed the font using the font dialog change the “Complex scripts” font to a font that supports the script (SultanMusnad), and then it seems to display.

Thank you, Lorna, I’ll give that a try!

1 Like

Greetings, Lorna - I have been trying that, without success. I can get a supporting font to appear in the upper box (under where it says “Latin Text”), but it refuses to appear below (under where it says "Complex Scripts{. I’ve tried reinstalling of the font and anything else I can think of. Sorry to be a pest, but I need this font! Thank you so much! --James

I don’t know what version of Office you are using, but the only other thing I can think of is that you haven’t enabled a complex script? If you use Office 2019 it would be something like: Files/Options/Language (within Word) and Add additional editing language and add something like Urdu or Arabic. Then you have to close all Office apps and reopen them.

I’m sure Microsoft 365 is similar, but I don’t know what the syntax would be.

If you already have that, then I’m a bit stymied on what to do.