KAB Keyboard gives just a black box after install


I created a keyboard with KAB 11.2 and tried to install it on a couple of phones, but on both I just got black boxes instead of a keyboard, and an error message. It appeared upon opening the app, and upon trying to use the keyboard. The Spanish error says,
"Error en el teclado cloud:Winchus para el idioma que." Roughly,
"Error with cloud keyboard:Winchus for the que language." or
"Error with keyboard cloud:Winchus for the que language."
(“Winchus” is the name of the Keyboard and “que” the ISO code for the Quechua language family.)

Android 11:

Android 13:

I was sure to reboot the phones after installing the keyboard, but got the same result.

It looks like this post might be related:


This is what Microsoft OS I am running:

Edition	Windows 10 Pro
Version	22H2
Installed on	‎1/‎05/‎2021
OS build	19045.4170
Experience	Windows Feature Experience Pack 1000.19054.1000.0

Here is my .kmp file which I built with Keyman Developer 16.0.147:

Here is my Keyman Developer project folder:

Also, I tried adding the keyboard via the Keyman App, but was unsuccessful. Here is a video showing what happens when I try to add it:

What do I need to do to make this keyboard work?

Is there anything else you need?

Thanks so much!

Hmm, I was able to install your teclado_quechua.kmp file on my Keyman for Android (17.0 beta).

Maybe the .kmp file didn’t quite copy on your device? In this screenshot from your video clip

The kmp file size is 9.33 kb but on my computer and on my phone, it shows 18.9kb


Can you also attach your KAB apk file?

Thanks! Really great observation on the file size. That’s really bizarre. I have no idea how that happened. I downloaded the file again and tried again with the Keyman app. This time it got me some funcionality, though the Ñ key on the right is missing on all layers, and none of the keys “flick.”

Here is the APK:

I’m away from my computer at the moment, but I will want to check if I gave KAB the big .kmp file or the small one.

Does that APK work for you?

Installing your KAB file, I got the same errors as you.


and none of the keys “flick.”

The mobile apps handle flick gestures in 17.0. You can try on the pre-release

Maybe you repurposed a spacer key in your keyman-touch-layout file:

                "id": "U_00F1",
                "text": "ñ",
                "sp": 10

The "sp": 10 means Keyman treats it as a spacer

Does not render the key, but leaves a same-sized gap in its place. The key cannot be selected

I think if you remove those lines on your missing keys, they should appear.


Thanks so much for your help!

I downloaded Keyman Developer 17.0.302 Beta and recreated the .KMP file (after fixing the issue with the Ñ key in the different layers). I added that to KAB, built the app, and installed it. Unfortunately, I have the same black box problem.

The Ñ key is working in the Keyman app though, fortunately.

Any ideas on how I can get my KAB app working?

Thanks so much!


Hmm, I used your kmp file in KAB 11.2 to make this apk and it installed on my device.

Thanks so much Darcy! I installed your APK and it works! I did some more troubleshooting (including redownloading and reinstalling KD and rebuilding the .KMP file) and got it to work.

I really appreciate your help!

Hi again,

I wasn’t able to get this to work in my stand-alone KAB app. Which Beta apps do I need to get flicking to work? Keyman Developer, Keyman, or Keyman for Android?


You’ll need an app using Keyman Engine 17.0+ which at the moment would be Keyman for Android (17.0 beta) and Keyman for iPhone and iPad (17.0 beta).

Your version of KAB is using Keyman Engine for Android 16.0.

Ah, thanks for clarifying! Is there any idea on when flicking capability is coming to KAB?

Well, KAB is maintained by a separate group of developers.

And it’s dependent on Keyman going from 17.0 beta pre-release to stable release. That’s still a few weeks away :crossed_fingers:

Ah, ok. That helps a lot! Thanks so much for the info.