Issue with image file names in Bloom Reader

bloom-reader

#1

In the workshop we did in Guatemala in September, one student ran into an issue with some images not showing up. The problem lay in the names of the image files. For example, one of his images was named thisisafilename(1).jpg When I renamed the file to thisisafilename.jpg, the image appeared in Bloom. The problem was the ().

The same thing happened when he had two different image files that shared the same name. If he used an image called “image1.jpg” on page 2 and used a different image that was also named “image1.jpg” on page 5, the image on page 5 would not appear in Bloom Reader. Is there a way for Bloom to look for these kind of file naming anomalies and fix them? My Kakchiquel brothers would appreciate any efforts you can put into this issue. Thank you in advance!


#2

@Marty
Could you please clarify if the images are not showing up in Bloom, Bloom Reader, or both?

Your first paragraph mentions problems with images appearing in Bloom and your second paragraph mentions problems with images appearing in Bloom Reader. Is that accurate?

Thanks


#3

Yes, he was able to bring the images into Bloom with no issue. The images did not show up in Bloom reader, but instead, a blank space where the image should have been. So somewhere in the transfer, because the image name was a duplicate or contained “(1)” it wasn’t recognized by Bloom Reader.


#4

I just tried both scenarios using the latest Bloom (4.3.2) and Bloom Reader (1.2.0).
Could this be tried again with the latest versions? It seems that we may have fixed the problem…

Otherwise, please submit the book in Bloom using Help -> Report a Problem.

Thanks,
Andrew