Installing WASTA on Mac M1 ARM via UTM


I am trying to install Wasta on a Mac using apple silicone M1 via UTM. I successfully installed Ubuntu this way, but when I executed the migrating commands I found on the How to turn Ubuntu into Wasta-Linux page, the machine crashed and wouldn’t boot. Alternatively, I downloaded the Wasta iso and tried installing it as a new virtual machine, but that also lead nowhere. Am I simply attempting something impossible?


Aah, I just noticed that the Wasta iso does not include ARM in its description… so yes I believe I am attempting the impossible.

It isn’t necessarily impossible, but the performance would be terrible. I would check with @rik-shaw whether there is a plan to include arm support.

Hi Chris,

I was just trying to install Field Works 9 via the flatpack instructions on Ubuntu running on an M1 Mac. However, it seems that flatpack packages are not architecture agnostic and also need to support arm64 architecture.

This was the error I received.
Reading package lists… Done

N: Skipping acquire of configured file ‘main/binary-arm64/Packages’ as repository ‘Directory Listing jammy InRelease’ doesn’t support architecture ‘arm64’

I wonder what the process would look like for compiling FieldWorks 9.0 to support arm64 architecture as well?

I was able to find a work around via windows running on UTM. Windows 11 has a trial version designed to run on arm64 architecture. I was able to download the windows version of Field Works on it.

@nate_shaver sorry I missed this discussion earlier. I have a “wasta-fied” Ubuntu install on a PineBook Pro (ARM64) so the packages should exist for you to start with an Ubuntu base and add Cinnamon and the other bits on top. So I would be happy to work with you to get this going.

But I suspect your main goal is getting a functional Fieldworks. As you have found, I don’t think the Fieldworks flatpak builds support Arm (I haven’t tried, but could if we want to look at this further), and I am not sure that it would be possible.

Please update me with your current situation and if you want to look into this further.

Hi Rik,

Thanks for your response. Yes the end goal was FieldWorks and the arm64 architecture was not supported when I made the attempt with flatpack on Ubuntu. My workaround has been to use an early build version of Windows 11 designed for arm architecture on UTM. I was able to install FieldWorks, Keyman etc and they are working decently well.



Glad you are able to get working. The Linux builds of Fieldworks will remain as they are as the team doesn’t have the capacity to keep them updated to stay in sync with newer Windows releases. So all around as a Fieldworks user I think it is probably better for you to be using a Windows environment.


Hi Nathaniel,

Your post 6 months ago inspired me to check out Windows 11 on UTM for the purpose of running SIL Windows software on my Mac M2 and I’m happy to report it “just works”. I created a youtube video to demo the installation process, which you can find here:

Windows 11 ARM performance with SIL software is surprisingly good - I am not disappointed.

Thanks for the inspiration :slight_smile:


Glad it worked well for you. Thanks for making the demo video.