I created an azerty keyboard but it keeps writing in qwerty

I created a keyboard in the developper by using an azerty base and adding some letters when I use the alt key. The keys that I have added work but the others keys are writing in qwerty. How can I change this ?

Welcome Ilona! I don’t have enough information from you to diagnose it, but one thing you should check is in Keyman Configuration make sure you have an AZERTY keyboard selected.
Steps:

  • In the bottom right, right-click on the Keyman icon:
    image

  • Select Configuration… (on the right)
    image

  • Select Options tab and Base Keyboard

  • Then choose an Azerty keyboard as your Base keyboard (maybe German).

You may need restart your computer if it doesn’t work on the first try. Not sure.

Probably “Base keyboard” French to get AZERTY layout.

German is QWERTZ, French is AZERTY :smiley:

Um, yeah. I knew that, I just forgot!