Custom Keyboard Fails to Install on Some Android Devices

I created a custom keyboard and it installs fine on many Android devices and so far all iPhone devices but on some Android devices I couldn’t get it to install and on some I had to take particular steps to get it to install. I have a screen capture but I don’t see how to attach it so I’ll try to describe the situation. In all cases a window pops up at the bottom of the screen after the .kmp file is downloaded. In the cases where it worked that window had the .kmp file name as a link with Download and Cancel buttons. In some cases the Download and Cancel buttons were replaced with a single Open button. If I clicked on the open button the install didn’t work but if I clicked on the .kmp file link the install worked. In two cases (out of about 10) there was no .kmp file name link, just the Open button. In this case I couldn’t get the keyboard installed. In both case I had the user try the install using Chrome. The people who are using the Keyboard aren’t very technical so I wasn’t able to get the Android version information yet. What all can I check to make sure that the installation should go ahead properly. Thank you in advance.

Welcome to the Keyman community, Kclifford.

I presume that you have Keyman for Android installed before you make an attempt to install the custom keyboard. I need a few details to be able to help.

  1. Are the Android devices running Android 4.1 or above?
  2. How do you share the .kmp? Via email?
  3. Have you followed all the steps here: https://help.keyman.com/developer/11.0/guides/distribute/install-kmp-android
  4. Could you share the keyboard with me in the direct message so that I can test it out on my device?

Hi Makara. Thanks for your reply and sorry it took so long to respond. Yes there are now three devices where I can’t get the kmp file to install. All of them have the Keyman app installed. At least 2 of the three are running Android 9 on Samsung phones. I’m not sure of the specific model number of the phones. I shared the file via a members only website and unfortunately I don’t have the authority from the First Nation (Canada) that I work for to share the web site information or the keyboard. I will try to get it. In all cases (the ones that work and the ones that don’t), when clicking on the link on the web site a window opens at the bottom of the screen asking if you want to open the file. In the case where it doesn’t work, clicking on the Open button results in a “Can’t open file” message. I’ve followed the instructions you pointed to in step 3 and used Chrome to do the install. I tried installing from the File Manager on on device but couldn’t get it to install from there either.

Thank you for the info.

What version of Keyman for Android are you using? You may have to open the .kmp with Keyman.

You may send us a direct message with the keyboard attached so that we can try it out on our side and see if we can reproduce this error.

Sorry that you encounter this issue.

I’m not sure what version of Keyman is running but they would all be whatever version was available on Playstore as of July 4, 2019. I will find out specifically but it might take a little while. As for sending a direct message, how do I do that? I don’t see an email on the contact page.
I’m impressed with Keyman and how easy it was to develop a keyboard and most people had no problem installing. It something about a very specific set of phones and I haven’t been able to pin it down yet.

Thank you very much for your help.

Hi Keith

There’s a known issue #629 where the default Samsung file browser “My Files” fails to associate .kmp files with Keyman. I thought it could still install via Chrome “Downloads”, but maybe that’s certain configurations…

Thanks. I’ll take a look at that.

For Samsung devices I have found the most reliable method is to install firefox and download the kmp file via Firefox which prompts you to open the file in Keyman when it completes it’s download.

I was finally able to check with one of the people who was having problems and they tried the Firefox browser also without success.

The work around for now is to use EZ File Explorer on Android. I have tried on my Samsung and Nexus phones and it does work.

  • Install and open EZ File Explorer
  • Browse for the .kmp
  • Tap on it and you will be prompted to install the keyboard if you have Keyman installed in the device.

Please let me know if the problem persists.

An enhancement has been filed in Keyman repo (https://github.com/keymanapp/keyman/issues/1722), so in the future version this will no longer be an issue.

Thank you for your patience.

Thanks Makara. It would’ve taken me a lot longer to get to the point the keyboard is currently at if it wasn’t for the great work that’s been done on the Keyman app so I’m grateful.

Regards,

Keith

image002.jpg