Conflict between skype and keyman


#1

My Keyman keyboard works everywhere but in Skype, where it reverts to the Microsoft Russian keyboard.

Windows 10 Pro version 1803
Keyman version 11.0.1350.0
Skype version 8.40.0.70
Keyman keyboard: Cyrillic Phonetic a
My computer is a Lenovo Thinkpad T580/P52s

Using the Cyrillic Phonetic a option, typing should give <яшерты>, but instead I get <йцукен>.


#2

That’s curious. Can you let us know which version of Skype you are using? The desktop version or the one installed through Windows Store?

Earlier versions of Keyman did not work with the new Windows Store version of Skype but version 11 should. Did you install Keyman as an upgrade or as a standalone install?

There are some additional diagnostic steps we can take, but they involve more work and are a bit more technical; if you are willing to try those, let me know.


#3

My computer is brand new. I had been using a TOshiba for years with no problem, and today was the first time I skyped needing it on the new computer.

The skype version is 8.40.0.70. I didn’t install it through the Windows Store. It was just there on the new computer, and when I used the same account, it apparently knew who I was.

I installed Keyman straight from the sil website. Since this is a brand new computer, there was no reason to upgrade.

I’m willing to try whatever. This is something I use regularly. What’s really weird is that it only is a problem in Skype. I can get the right result in Word, for example, without even switching the keyboard.


#4

Okay, if you could capture a debug log, following the instructions at https://help.keyman.com/kb/76, that would be a great start. Exit Skype before starting Keyman, then start Keyman, start Skype, try to switch keyboards and type, and then exit Keyman.

Send the resulting log file to us. Note that version 11 of Keyman stores the log file in %localappdata%\Keyman\Diag (Press Win+R and paste that location into the Run dialog that appears) and the log file will have the extension .etl, rather than .log.


#5

I tried following the instructions at the link you sent, but it didn’t work. When I got to the point to press the “pause” button, nothing happened, and when I went to look for the log file, I found that folder but there was nothing from today.

What should I do?

Brian


#6

Sorry, I should have been a little clearer. We need to update that KB article for Keyman 11; in the meantime, enable Debugging per the article, then take the steps from my previous post (reproduced here):

  • Exit Skype before starting Keyman,

  • then start Keyman,

  • start Skype,

  • try to switch keyboards and type,

  • then exit Keyman.

  • Send the resulting log file to us. Version 11 of Keyman stores the log file in %localappdata%\Keyman\Diag (Press Win+R and paste that location into the Run dialog that appears) and the log file will have the extension .etl, rather than .log.


#7

I followed these instructions exactly. There just isn’t anything from today in the localappdata folder.


#8

Okay, I’m not sure where to go from here. What do you have in the %localappdata%\Keyman\Diag folder?


#9

Do you do Bomgar? I would be happy for you to connect to my computer and work through it.


#10

I should be able to organise a time this week to run a test with you. I will contact you via direct message.


#11

After a lot of digging, we got to the bottom of most of this. The issue was that the permissions for the registry key HKCU\Software\Keyman were incorrect – the ALL APPLICATION PACKAGES Read permission was applied to that key, but no subkeys or values. I have not yet figured out why this happened. I have documented this, including the workaround, at https://github.com/keymanapp/keyman/issues/1680


#12

We did not get to the bottom of why the event logging was not happening. Another time, perhaps.