Code not displaying In the Editor in KMD 16.0

Having set up a new project, and imported the Windows Swiss German keyboard, the code does not display in the Editor. From KMD 9.0 I’ve upgraded successively for several versions and had reached 16.0.144. To be sure there wasn’t a problem with this I did uninstall/reinstall but nothing changed. Windows Compatibility suggests changing to Win 8 settings which doesn’t seem right given that KMD 14.0 ran happily on Win10 Pro 64-bit two years ago developing a keyboard related to the new project.

Strangely, the code for the earlier project does not display either.

Assuming there is no bug, I seem to be missing something blindly obvious. What is the answer, please?

Hi Dennis…
Would you be able to give us a screenshot of the issue?
In the Details tab, it’s just a dialog box.

On the Layout tab, the “Design” tab might be selected if it’s a simple keyboard. But, you can then choose the Code tab (see bottom of screenshot) and I do see the code.

If this is where you are not seeing code, you might want to check the font window (Keyboard/Fonts) and make sure you have a font selected there:


I don’t see any way to remove the font, so the only issue might be if you don’t have the font installed that Keyman is looking for. You could try choosing a different font.

Otherwise, we will need more information.

Not realising that Lorna had already answered, I tried creating a new project as you outlined.

From the Project menu, New Project, Import Windows Keyboard
Swiss German chosen from list (KBDSG.DLL 00000807)
(I selected “gsw” as BCP47 tag instead of “de”, but I don’t see that this would make a difference)
I filled in other fields (name, description)

Developer opened the new project. Opening the .kmn file, then clicking on the “Layout” tab shows me the code (since Design view is disabled due to the complexity of the code).

As Lorna suggested, a screenshot might help us figure out what is going on. Thanks!

Update: had to share a bunch of screenshots via PMs. Lorna and David can open the .kpj file and see the code. Uninstalling and reinstalling 16.0.145 (released Feb 01) has not made a difference. The code is not displayed in Layout>Code tab, yet the .kmn file opens in a text editor. Trying to select code with Ctrl+C has not revealed otherwise invisible code. This suggests that KMD is not loading the code.

Trying to run KMD 16 in WINE on Wasta-Linux has not worked.

It is quite unclear why KMD is tripping up on this machine which has been used to create six previous keyboards.successfully. Any further suggestions??

@Marc Any ideas? I do note that the .kmn file is UTF-8 with BOM, but both Lorna and I were able to read it normally with Developer (though I’m using v17).

Can I see the screenshots? It could be that antivirus is blocking something from loading so the text editor component is not running correctly, but hard to guess from here.

@Chiff, can we setup a remote support session to diagnose directly? I’m not seeing anything obvious in the screenshots that @drowe forwarded to me. I will send you a private message on the forum with remote support options.

Marc, I’m in the UK. Available from 08:30 UTC but not all days. Using Norton AV suite.

Keyman team had setup a remote support session with this issue.
We found out that having several Anti-virus software could interfere with Keyman Developer (as the software has been doing so).

Please feel free to create a new topic if there are any questions or if a new issue occurs.