BUILD FAILED No such file or directory

Message:

Failed to build apk. Possibly internet connection problem. At the first build, the compiler downloads the necessary files from the Internet.

What could be the source of problems?
Log attached. output.log.zip (2.1 KB)

The first time that you do a build, you need to be connected to the internet. There are libraries that get downloaded and reused for future builds.

I know this well. )
Internet is on. I have tried all the latest versions of the RAB. The result is the same in every case.

I’m not a RAB expert (or even a novice), but I use and support Wasta-Linux. Looking at your log file I see that you’re using a Mac, and it reports this:

  • What went wrong:
    Gradle could not start your build.
    Could not create service of type FileHasher using BuildSessionServices.createFileHasher().
    Timeout waiting to lock file hash cache (/Volumes/WORK/BUILDER/TEMP FOR BUILD/RAB.008/a/.gradle/6.5.1/fileHashes). It is currently in use by another Gradle instance.
    Owner PID: unknown
    Our PID: 16339
    Owner Operation: unknown
    Our operation:
    Lock file: /Volumes/WORK/BUILDER/TEMP FOR BUILD/RAB.008/a/.gradle/6.5.1/fileHashes/fileHashes.lock

So it looks like you need to release the .lock file. I’m not sure of the exact process for this, but rebooting your computer will probably do it. Or it could be as simple as closing some other App Builder instance that might be running at the same time? If all else fails, you could force delete the lock file, but I don’t know what the consequences of that might be and would not recommend it from my relatively ignorant perspective.

Thank you, Nate.
It did not help.

I transferred all projects to the Windows machine. Installed RAB. And … the situation is the same as on the MAC mashine.

Is there a problem with keystore?

It may be good news that you don’t have the same problem you had on the Mac (yet).

This screenshot says that RAB thinks your computer is offline (offline mode), and it was not able to find Gradle 4.0.1 (the android builder) that was supposed to have been downloaded. I don’t know what the Cyrillic text says afterwards.
If you were connected to the internet while building on Windows (I can see that you were on Wifi when the screenshot was taken), try turning off the “Metered” connection for your wifi network and building again.

Often, those with slow connections have to run the build a half-dozen times until everything gets downloaded.

An interesting observation. I have been using the RAB for 3 years now. From time to time this problem arises, as if I do not have an Internet connection. Usually, after 2-3 days everything went well. I could build the application. But this is not possible now. I even tried connecting via VPN. But it did not help. Internet is stable with a speed of 3 MB.sec.

Like Matthew observed above, your Windows screenshot says “Using compiler in offline mode…”.

Since it looks as if the compiler needs to go online to download new libraries, please go to Tools > Settings > Build Settings, and uncheck “Use compiler offline”.

Thanks to all the participants. However… Errors are repeated again on both machines (MAC and Windows) :sob: