Bloom Player within RAB 6.1

I just finished installing and compiling an app with RAB 6.1, in which I included a Bloom book.

I installed it on a Samsung running Lollipop. It only opened to a blank page that said in very small letters in the top left-hand corner “Loading Bloom Player…” but that’s all the farther it got.

I also installed it on my LG running Pie. It loads just fine. The audio plays perfectly, and the text highlights perfectly as it’s being read.

However, I lose all of the motion I programmed into the original book in Bloom. In my opinion, it’s a small price to pay for the ease of getting a Bloom book incorporated into my RAB app.

Is this normal, or should the motion (Ken Burns effect) be carrying over to the Bloom Player?

BTW, kudos to the programmers who are making this work!!

The Bloom Player in RAB is still in Alpha. Good to hear it works on one phone but not good it does not work on both.

This may take a few releases to get right. I is being worked on by collaboration between the Bloom team and the RAB team.

You do have the option to change the Book Typ: Bloom Book – convert to Picture Story Book though this method will probably go away once the Bloom player is working well.

When all else fails I run a script to convert the Bloom book to an SFM Picture Story Book.

I am wondering if you have any update regarding this issue with your device that was saying “Loading Bloom Player” and that’s all the farther it got?
I am having the same thing happen with a tablet running Android 6.0.1, but with a recently created app. So I am wondering whether your issue has been fixed or is related to mine.

Bloom Player has had several updates since that time. If you download the Android Bloom Player does your Bloom book load into that player?

That is a good idea, I think you mean try out using Bloom Reader app and loading the book in there. I haven’t done that yet because I got a resolution.
The resolution was that the tablet didn’t have Android System WebView installed, which is used by Bloom Player. So installing that fixed the problem.
The Bloom folks said they are going to try to make it so a more helpful error appears in the future indicating what to do about it if this happens.

Hi. The Bloom team doesn’t monitor this RAB forum, so go ahead and @ mention one of us when something related to Bloom comes up and we’ll be glad to help.

We are planning to soon improve the experience you get when you Android phone does not have the necessary components for Bloom Player. See here for details.

As far as I know, if you have at least Android 5.0, then the problem is that the phone has very old “Android System WebView”. It would normally auto-update. Go to the Play store, look up this component, and ensure that it is not stuck on some 2014 version.