Active keyboard doesn't type

My Windows 11 laptop has stopped typing the active keyboard. I use Burmese, Thai, and IPA keyboards.

I have used Keyman for many years with no problem. I am using the most recent version 16.0.147 (and even when I rolled back to 15, the same thing happened). I have gone through many Windows updates and it hasn’t fixed.

Keyman is visible in the notification area and it shows the correct keyboard, but it doesn’t actually type with that keyboard

I am just having to use the web interface instead, which is a hassle.

Thanks for your help!

Welcome to the community @Ideas!

I’m sorry that you’re experiencing this issue. You mentioned that your Keyman keyboards suddenly no longer working. Do you refer to all Keyman keyboards you have installed? Also, do you recently install any applications?

Can you make sure that Keyman is running? you can search for Keyman and click on “Start Keyman”.

Does it output anything? and what does it output instead?

You can try to uninstall and install Keyman again. If this doesn’t work, please send me the diagnostic report so we can take a look at the issue.

Thank you!

Thank you for your response. I tried to send you a diagnostic report, but it gave me an error message:

Keyman is running. But when I activate a keyboard using a keyboard shortcut or by clicking on the keyboard, my typing just continues to be Latin characters.

I recently installed Keyman for my wife on her new laptop. It works fine for her.

Do you install any anti-virus software on your computer? It could be blocking you from sending the files. Take a look at this issue.

Also, can you try to switch the keyboard on and off?

I think the problem preventing me from sending you the diagnostic is that the file size is too big (10 MB), like the issue you sent a link to. Here is the warning message I get earlier in the process.

Can I send that diagnostic file to you by some other method? Or how do I shrink the file?

I am just using the built-in Windows antivirus.

I can easily switch keyboards on and off but there is no change to what I type.

Thanks

Please save the files into your computer (Files → Save as) and upload it into Google Drive or Dropbox and you can share me the link.

Here is the link: Keyman diag.tsi - Google Drive

Hi @Ideas,

I have checked the report. Can you try to disable touch input on your computer? and reinstall Keyman again?

Please let me know how this goes!

Thanks.

I disabled my touchscreen, uninstalled Keyman, rebooted, reinstalled Keyman and my keyboards and rebooted. It still does not work. I enabled my touchscreen again and it also still doesn’t work. I tested it in Microsoft Word and LibreOffice.

I had previously disabled the touchscreen on my wife’s laptop for other reasons before installing Keyman, and Keyman does work on her laptop

We can have a remote session to look into this. Please let me know your available time.