Weird UI changes in Android app

In our latest builds of our Android app we are experiencing some very weird behavior in the Index tab with the reversals:

At first everything looks normal but when you click on an entry and then click on the back arrow in the upper-left corner this happen:

The standard Rohingyalish vernacular gets replaced by the Arabic reversal/vernacular. If you click again on another entry:

It continues to switch to Arabic.

You can test this behavior within our app:

It happens for all reversal indexes.

I can’t explain the problem and I haven’t found a solution. My only guess is that Arabic is the first vernacular in our lift file and it is shown despite the order fixed in DAB is Rohingyalish first.

Any hints for how to fix this are very welcome.


Here’s another example:

In the freshly started app I switch to the Semantic Domains tab (which is in fact a reversal Tab for a language that is used for the semantic domains).

At first it shows normal:

Then I click on the 1.1.1 Sun entry and it shows me the following list:

Then I click the arrow to o back to the screen before and it looks like this:

Several words, seemingly random have been replaced with their Arabic script counter parts.

My assumption so far: Since the Arabic script appears as the first vernacular in our LIFT database file due ?due to alphabetical sorting? (rhg-Arab) it shows first here instead of the Rohingyalish that was there before (rhg-Latn). Maybe the refreshing function for the screen just chooses the first vernacular to be found ignoring the specific lang= attributes.

So could anyone help me to create an xslt file to change the order of our vernaculars in the xml file? (So I can test this hypothesis).

Otherwise this seems to be a bug in the reversal tabs within DAB when confronted with more than one vernacular script???

This behavior has a major impact on the usability of our dictionary so any help to solve this is very much appreciated.

I know I have an older version of your project but can I get an updated version?

So what I am seeing is that if you choose a section. then when you come back from that view to the index view, the expected script has changed to another script. That occurs for the domain looked at and the semantic category before and after. The rest are as before.

In the example you gave you clicked on Sun, is tah correct?

I’d like to know if changing the order in LIFT fixes the problem.

Dear Ian,

at this link you will find the actual LIFT databses that go into the latest version of our apps:


P.s.: Yes, I clicked on sun.

Hi Ian,
I’m Mickz’s colleague, and I’m picking up this project from him. We’re still having this problem which is preventing us from releasing a fully functional version of the dictionary app. I tried what you suggested – switching the order of the fields in the LIFT database files from:

sometext sometext sometext sometext sometext TO sometext sometext sometext sometext sometext

I tried this and it didn’t fix the problem he described here. Do you have another suggestion of what we could try? Or is there a fix that needs to be done in the app framework?

Sorry for the delayed response.

If I make the rhg-Latn the first language in the Languages section (right side). (Select then click hold and drag.)

Then the reversal is always comes back to the rhg-Latn as the second language. If you have Arabic first it will always be the second language in the reversal. I am not sure how you got rhg-Latn as the second language in the very first image.

I am not sure how you got rhg-Latn as the second language in the very first image above.

If you do this then you need a reversal made for the Arabic.