Way to tell Bloom that my book isn't really a derivative

Awesome! Happy to keep working.

Andrew, I am curious though … has this not happened to anyone else before??
Something new? It seems to be my “thing” to find these glitches :wink:

I have experienced problems with the “Adapted from” statement as well,
early last year, as the Bloom team knows. I ended up editing each book
manually to remove or edit those statements where they turned up
unexpectedly, but this was a LOT of hard work. I would love to have a
button to remove the problem statement!

Kim Blewett
Language Technology Consultant (LSS)
SIL Papua New Guinea
kim_blewett@sil.org

Hello Kim! Thanks for this input.
Would love to know how you manually removed those statements.
I can’t seem to access that at all. The only option I see is for me to rebuild each book that was built in the first language collection. That would be a lot of work!! and shouldn’t be necessary.
Any advice would be helpful.
I’m ready to hit it again today … need to keep moving ahead.

Hi Chris,

You don’t need to rebuild the books; just continue building them in new
languages, as Andrew advised. They have promised to get those unwanted
statements removed before you publish. You do not want to try to
remove them yourself, believe me! It is tricky and time-consuming unless
you can write a “script” that will do it automatically, which I don’t
know how to do. That is the job of the Bloom team. :slight_smile:

I am curious about a couple of things:

  1. In the Big Books and Basic Books collections, are you sure the
    original books—the ones you tried to copy into a new collection—do
    NOT contain the “Adapted from” statement?
  2. When you copy one of the Big or Basic books to a new collection,
    is this second collection a Source collection or a Vernacular
    collection? If you’re willing to try it just one more time, you
    could create a new collection in Bloom. Make sure this new
    collection is a Source collection, not a Vernacular one. Then try
    copying a Big or Basic book into it. One of Andrew’s replies
    indicated that books copied into a new folder behave differently
    based on this distinction.

Kim Blewett
Language Technology Consultant (LSS)
SIL Papua New Guinea
kim_blewett@sil.org

Hi again, Chris,

I’m wondering whether John’s “Option 1” (below) got missed in this
discussion. To expand a bit on what he wrote, you can add a new language
to a book collection without losing any of the other languages that have
already been added. You can only have three active languages at a time
in any collection, but you can take out one language temporarily and add
another. So, for example, my Basic Book collection is set to Rapoisi,
Spanish and English. I can change Rapoisi or English to, say, Halia
(hla). Then if Halia is Language 1 for the collection you’re ready to
type, but if Language 3 is Halia you can enable it as a second language
for each book while you edit. I think you need to keep Spanish as
Language 2 because the Credits page uses Language 2.

Now I can no longer see the Rapoisi version of my book, but it is in
still present in the book’s encoding. Actually, it may appear in the
bubble beside each text box. When you get ready to publish the books in
a particular language you can change languages 1 and 3 to whatever you
need them to be and your books will again display the vernacular.

Does this help you at all?

Kim Blewett
Language Technology Consultant (LSS)
SIL Papua New Guinea
kim_blewett@sil.org

Thanks, Kim.

  1. The books in the originals/first collection do NOT contain the “Adapted from …” statement.
  2. Terminology may be confusing my communication. I’ll try to explain better.

Because I am building many books in several languages I wanted to be very VISUALLY organized on my computer.
Thus I did not start with the “Option 1” by adding “other languages” which are then “hidden” (I think?) on my computer.
I want to see all of them at any time … clearly visible and separate in each language folder.

I started with separate folders for each language collection. The first book created in the first collection was started from the Bloom SOURCE collection. From there they were duplicated inside Bloom inside the same folder.

I did DIFFERENT books (different subject) in the next language … the same way as in the first language folder.
These DO transfer/copy to the other language folders.
THOSE IN THE FIRST FOLDER DO NOT.

I’ve tried every test (new languages and new folders) and combination I can think of but cannot get the books from the first language to copy into the others WITHOUT that message. I CAN put in a new language though with no problem.

The other languages work fine between each other.

Not sure if this makes things clearer, Kim :slight_smile:
I’ve spent many hours trying to explain this dilemma and have sent files on to the Bloom team.
I’ll just carry on making those books anyway and trust the team to fix this later.
Thanks for trying to help.

OK, @Chris, thanks for waiting. Please try out the latest Bloom 4.6 beta. In a book that incorrectly thinks it is adapted from another book, in the Copyright and License dialog, un-check this checkbox:

image

Please let us know if that takes care of this problem for you.

–John

I’m not sure that’s true exactly: it seems to me that Bloom will not use Language 1 or Language 2 on the credits page unless it already knows the translation of the full-text versions of the various CC licences in one of those languages. In my case, I see it using Language 3 (Russian for me) on the credits page (I mentioned this, without listing the language numbers, here: More freedom to edit front/back matter).

Hello John,

It’s been a long time but I am ready to get back into building Bloom books this winter.

I will be meeting with the translator I have been working with all summer real soon … in Mitla, Mexico … to go over all the books we have created.

I have installed Bloom 4.6 Beta.

I see no change … still having the same copyright issue as before. They are still showing the “adapted …” message.

My “Copyright and License” dialog box does not have the added field to un-check as you show in your email below.

I’ve tested new collections and books.

Still looks the same as in the Bloom previous versions.

It also still messes with the text size on the landscape books … but this I can work/live with.

Hi Chris,

Great to have you back working on Bloom. Of course down here, it’s holiday time.

I see no change … still having the same copyright issue as before. They are still showing the “adapted …” message.

Here are some tips towards crossing the artist-programmer communication divide :wink:

If I gave instructions, go ahead an quote that so we know we’re talking about the same thing:

in the Copyright and License dialog, un-check this checkbox:

And then say something like “I don’t see this that box”, or “here’s a screenshot of what I see”.

Or "

What I want to do is____
and so here is exactly what I did: _____________ (often with a screenshot)
When I did that, I expected to see __________
But instead, I see ________ (with a screenshot).

For screenshots, windows has a “Snipping Tool” that’s easy to use.

We’ll get there!

jh

Sorry, I’m assuming all that dialogue from before is still available??
Just responded to your email, John.

Chris DeJong

“Please try out the latest Bloom 4.6 beta.”

Did that.

"In a book that incorrectly thinks it is adapted from another book, in the Copyright and License dialog, un-check this checkbox:

image"

Did that.
Below is what I see … same as in the previous version.

Thanks Chris. I not from your screenshot that the “Copyright and license this translated version” checkbox is absent from your second screenshot. So I’m confused about how you you “did that” (un-checked the checkbox)?

I’ve asked a teammate to see about screen-sharing with you.

Hi John.

I didn’t. That’s the point. It’s not there for me to do anything with :slight_smile:

Yes, Colin and I spent time together yesterday … and will again in a few minutes.

He is most helpful. Thank you for arranging that!

Wow, what difference to be “on the same page” :slight_smile: Screen sharing is the way to go!!

He thinks he knows what is happening and why. He’ll get to the bottom of this.

@Chris,
We believe we have a solution and are implementing it now.
Using the file system to copy a book with no copyright information from a source collection to a local language collection and editing it is far from a typical scenario, so we didn’t catch the gap in the logic.
After our forthcoming change, the logic to add the “Adapted from” statement should be the same as the logic for presenting the missing checkbox.

I’ll keep you informed on when the change lands in 4.6. I can’t promise, but hopefully by week end.

We in PNG have also struggled with wanting to remove the “Adapted from”
source copyright from books that have accidentally gotten turned into
“sources” too soon. The checkbox to show or hide the source copyright is
a partial solution for us, but we really also need a way to permanently
remove/add/edit the originalCopyright and other originalLicenseXx fields
from a book, to clean it up and make its credits be what they really
should be.

The new checkbox seems to be temporary–it doesn’t change the book xml
metadata, just hides a piece or two. It seems like it would be easy for
someone who doesn’t know what they’re doing to flip to the “wrong”
setting for a book.

Maybe if books get created (and proliferated into many languages)
wrongly that’s just our tough luck; we have to edit each xml file to
clean them up? An advanced feature that can be hidden by adminiatrators,
to edit original copyright/license fields from within Bloom–which is
where normal people/OWLs and such have to go to see that something is
wrong-- would be very welcome. This is not an uncommon occurrence, I
don’t think.

Thanks!

Kim Blewett
Pacific Area Language Technology Coordinator
SIL International
Language Technology Consultant (LSS)
SIL Papua New Guinea
kim_blewett@sil.org

Kim,
Thank you for that feedback.
I believe John is aware there is still more to be done in this area, but he is currently on vacation for a bit and then we have the holidays, so I’m not sure if/when he’ll be able to comment.

I’m a little unclear from your post. Is there something this new checkbox feature is not doing the way you expect it to?

If there is a new feature(s) you would like to see in addition to what we have done in 4.6, would you mind creating a new Feature Request(s) so it/they can be tracked separately?

@Chris
This is now deployed in the latest beta, 4.6.107.

Thank you Andrew.
We just got back from Mitla. I’ve followed your messages but have not yet had time to checking anything out.

Will in a few days. Look forward to it and trust it will be the solution.

Chris DeJong