Uninstalled Keyman in kubuntu 18.04 and now i cant change my keyboard layout

hello, Kubuntu 18.04 user here, I have installed KEYMAN by adding a PPA. after testing it a bit and installing one keyboard layout for PASHTO language, I decided to uninstall the software KEYMAN along with the installed keyboard. Now i cant change my keyboard layout using the keyboard shortcut or by clicking on the keyboard layout icon to Default PASHTO keyboard. Does anyone have any idea how to fix this?

Hi there

Since you uninstalled Keyman, can you tell us what keyboards you have remaining?
KDE System Settings --> Input Devices --> Keyboard --> Layouts tab

As far as I know, you’d need at least two keyboards available for the keyboard shortcut to toggle.

Maybe this Ubuntu guide will help you

i have English, Arabic and Pashto available for toggling.
i can toggle between Arabic and English but when i click on Pashto keyboard layout, it does not work.

Was the Pashto keyboard working for you before you tried installing/uninstalling Keyman?

On two separate computers, I’ve tried installing these Ubuntu keyboards (18.04) but they don’t work for me. Typing with the keyboards only generates Latin characters

  • Pashto
  • Pashto (Afghanistan, OLPC)

I was able to install a different Pashto keyboard that worked:

sudo apt install ibus-m17n

Then add Pushto; Pashto (phonetic (m17n))


only generates Latin characters??? this is really unbelievable for me.
I have attached an screenshot of the Pashto keyboard layout that is shown on my Kubuntu.
you can go to “/usr/share/X11/xkb/symbols/” and find a file by the name “af”, inside of which you will find the Unicode characters used by Pashto keyboard. maybe you don’t have this file in your system.

how did you add Pushto; pashto (phonetic (m17n)) ? did you use the terminal? if so, what are the commands that you used?

I checked the package “ibus-m17n” on my system and it was not installed, I installed it and still i can not change my keyboard layout to Pashto using the keyboard shortcut.

I’m guessing it’s a GNOME bug for why Pashto keyboards don’t work for me.

Reproducing the issue:

  1. I installed a new virtual machine with 18.04.1 Kubuntu
  2. Add the Afghani-Pashto keyboard, and I could switch to it and type
  3. Then I installed Keyman
  4. From Keyman Keyboards, I downloaded and installed Pashto (Afghanistan) Basic for Linux) keyboard (basic_kbdpash.kmp)
  5. From a terminal I enabling ibus and added the keyboard
  ibus-setup

Input Method --> Add --> Pushto; Pashto --> Pashto (Afghanistan) Basic
6. I saw the same issue you reported
(Ctrl-Alt-K no longer toggled keyboard)

Solution:

In the Keyboard - System Settings Module --> Layout tab
I removed Afghani-Pashto and added it back.
Afterwards, I could toggle with Ctrl-Alt-K

I tried your solution, unfortunately it did not work.
I removed and readded the Pashto keyboard and i still can not toggle it with keyboard shortcuts or with mouse clicks.

currently, i have three keyboard layouts installed, English, Arabic and Pashto.
I can toggle between English and Arabic as expected but when it comes to Pashto, it does not work.

the keyboard which i installed from Keyman is named Rachitrali-Pashto keyboard.
I think this Keyboard installation messed up the code in my system somewhere.

Sorry to hear that didn’t work.

Since you’ve already uninstalled Keyman for Linux, I’m afraid this forum for Keyman users may not be the right place for fixing your issue.

Keyman for Linux works by interfacing with ibus, so I think you’re troubleshooting some issue between ibus and Kubuntu.

I would suggest posting in the Kubuntu web forum.