Unable to install Keyman in Linux Mint 17 Cinnamon 64-bit

OS: Linux Mint 17 ‘Qiana’ Cinnamon 64-bit
Cinnamon version: 2.2.13
Linux kernel: 3.13.0-24-generic

I tried installing the keyman version 15 application from the commands given on the links:
Keyman 15.0 for Linux and http://packages.sil.org/.
But unable to install it. Please provide a guidance to resolve this issue.

Hard to say exactly, since you don’t say which of the install paths you used from those instructions. However, the script used to add the SIL repositories to Mint “fail” because they pull the Mint version name instead of the Ubuntu version upon which the Mint version is based.

If you look in your Software Sources,
image
you may see “Qiana” as the name after "Sil / ". In that case, edit the entry and replace it with “Trusty”. This will allow the SIL repo to find the version appropriate for your OS.

I haven’t done this for a while. Note that in my case, “focal” is also part of the deb URL.

Thank you for your response @JDWood,

I tried the below command to install keyman:
$sudo apt install keyman onboard-keyman

But got the message:
Reading package lists… Done
Building dependency tree
Reading state information… Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
keyman : Depends: python3-keyman-config (= 15.0.270-1~sil1~focal) but it is not going to be installed
Depends: ibus-keyman (>= 15.0.270-1~sil1~focal) but it is not going to be installed
Depends: ibus-keyman (< 15.0.270-1~sil1~focal.1~) but it is not going to be installed
onboard-keyman : Depends: python3 (>= 3.8~) but 3.4.0-0ubuntu2 is to be installed
Depends: libc6 (>= 2.29) but 2.19-0ubuntu6 is to be installed
Depends: libgcc-s1 (>= 3.0) but it is not installable
Depends: libhunspell-1.7-0 but it is not installable
Depends: libstdc++6 (>= 5.2) but 4.8.2-19ubuntu1 is to be installed
Depends: libxkbfile1 (>= 1:1.1.0) but 1:1.0.8-1 is to be installed
E: Unable to correct problems, you have held broken packages.

I also tried installing using the commands given in the link http://packages.sil.org/ for Linux Mint: (. /etc/os-release && sudo tee /etc/apt/sources.list.d/packages-sil-org.list>/dev/null <<< “deb Directory Listing $UBUNTU_CODENAME main”). But that too gave error.

I tried installing through software manager. It is showing not avaliable. (Please see the attached image)

Unfortunately Linux Mint 17 is based on Ubuntu 14.04 for which we no longer provide packages.

The easiest would be if you could update to a newer Mint version (>= 19).

You could also try to install an older version of Keyman that is available in your software manager (remove the packages.sil.org source first) - I don’t know what version would be available, if any - or install kmfl.

And finally, the hardest option: you could build Keyman 15 from source (stable-15.0 branch of GitHub - keymanapp/keyman at stable-15.0) - see keyman/linux-ubuntu.md at master · keymanapp/keyman · GitHub for some hints how to build on Linux. But you might run into dependency issues there as well if not all required dependencies are available on Linux Mint 17.

Thank you @EberhardBeilharz, I will follow the instructions as per your guidance.